概要
データベースとして Microsoft SQL Server 2000 SP4 を使用して、InterScan Messaging Security Suite (以下、InterScan MSS ) 7.1 Windows 版を利用しています。
InterScan MSS 7.1 Windows 版 Patch 3 を適用後、エラーメッセージが表示されて管理コンソールにログオンできません。
詳細
問題の現象
InterScan MSS 7.1 Windows 版 Patch 3 (ビルド 15240) 適用後、次のエラーメッセージが表示されて管理コンソールにログオンできません。
「管理データベースへの接続に失敗しました。データベース接続を確認してから、InterScan MSS 管理コンソールを再起動してください。」
問題が発生する条件
データベースとして、Microsoft SQL Server 2000 SP4 を使用している環境でのみ発生します。
原因
Patch 3 を適用すると、JDBC ドライバが 更新されるために発生します。
Patch 3 では、JDBC ドライバを更新し、Microsoft SQL Server 2008 に対応しましたが、このドライバは、SQL Server 2000 をサポートしていません。
対処
以下に示す手順で、Patch 3 (ビルド15240) 適用前のJDBCドライバにロールバックします。
InterScan MSS は Patch 適用時に、置き換えるファイルをバックアップしています。
このバックアップファイルを、手動で元の場所に戻すことにより、管理コンソールにログオンできるようになります。
作業手順
1. 「Trend Micro IMSS Web Console」サービスを停止します。
2. 次の場所に保存されている、現在の JDBCドライバファイル " sqljdbc.jar " を任意の場所にコピー(バックアップ)します。
"<InterScan MSS インストールディレクトリ>\ui\adminUI\webapps\ROOT\WEB-INF\lib\sqljdbc.jar"
3. 次の場所にバックアップされている JDBC ドライバ ファイル " sqljdbc.jar " を 手順 2. で示したディレクトリにコピーします。
"<InterScan MSS インストールディレクトリ>\temp\15240\backup\ui\adminUI\weapps\ROOT\WEB-INF\lib\sqljdbc.jar"
4. 「Trend Micro IMSS Web Console」サービスを開始します。
以上で作業は完了です。
- ご注意
InerScan MSS の Patch は過去にリリースされた Patch の修正内容を含みます。
このため、今後新たにリリースされる Patch を適用した場合には本問題が再度発生します。
この場合は同じ手順で JDBC ドライバをロールバックします。