概要
一時的に拒否されたメッセージがバウンスされず、遅延キューに残っています。なぜでしょうか。
詳細
事象
配信先メールサーバに接続できなかった場合や 4xx の応答コードで一時的に拒否されたメッセージは、IMSVA では遅延キュー (Postfix の deferred キュー) にいったん保存され、Postfix の再送設定にしたがって再送を試みます。
初期設定では遅延キューに保存される最大日数は1日に設定されていますが、2日以上経過後も遅延キューに保存され、送信元に配信不能通知 (バウンスメール) が送信されません。
初期設定では遅延キューに保存される最大日数は1日に設定されていますが、2日以上経過後も遅延キューに保存され、送信元に配信不能通知 (バウンスメール) が送信されません。
原因
まず、Manager サービスは毎日23時に再起動されますが、Manager サービスの開始時に postfix flush が実行され、キューにあるすべてのメッセージに対して再送を試みます。
しかし、その際にキューへの入れ直しを行うため、キュー ID が変更され、再送履歴もすべてリセットされます。そのため、メッセージはバウンスされず、遅延キューに残り続けます。
しかし、その際にキューへの入れ直しを行うため、キュー ID が変更され、再送履歴もすべてリセットされます。そのため、メッセージはバウンスされず、遅延キューに残り続けます。
解決策
問題の修正が含まれる IMSVA 8.5 Service Pack 1 を適用してください。