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ServerProtect の Patch 適用後、Trend Micro Control Manager のサービスが起動しない  

ServerProtect の Patch 適用後、Trend Micro Control Manager のサービスが起動しない

    • 更新日:
    • 17 Jun 2020
    • 製品/バージョン:
    • ServerProtect for EMC Celerra 5.8
    • ServerProtect for NetAPP 5.8
    • ServerProtect Ver5 5.8
    • Trend Micro Control Manager 6.0
    • OS:
    • Windows すべて
概要
ServerProtect for Windows (以下、SPNT) 5.8 Patch 5 を適用後、以下のエラーが発生し、
Trend Micro Control Manager または Apex Central (以下、TMCM) のサービスが起動しない状態となります。
 
=================
ローカルコンピュータ上のTrend Micro Management Infrastructure サービスは起動して停止しました。サービスの中には、ほかのサービスやプログラムで使用されていない場合は自動的に停止するものがあります。
=================

=================
レベル:エラー
日付と時刻:20**/**/** **:**:**
ソース:Trend Micro Control Manager
イベントID:800
タスクのカテゴリ:System
メッセージ内容:Trend Micro Management Infrastructure (TMI) が準備できていません。エラーメッセージ:  errcode=-107, MRFServer.cpp|108
=================

対処方法について教えてください。
詳細
Public

発生要件

本エラーは、以下の条件に全て合致する場合に出力されます。
 

  1. TMCM と SPNT が同一のサーバ上で構築されている。
  2. TMCM 6.0 SP3 以上(バージョン7.0 および Apex Central を含む) が適用/インストールされている。(※注1)
  3. SPNT 5.8 の新規インストール時に Control Manager エージェントを
    インストールし、TMCM 6.0 へ SP3 を適用した後に SPNT 5.8 へ Patch(※注2)を適用する。
    またはTMCM 7.0以上とSPNTが同居している環境において、Control Manager (TMI)エージェント(※注3)からMCPエージェントにアップグレードが発生するPatch(※注2)を適用する。

"ServerProtect for EMC Celerra 5.8" (以下、SPEMC) や"ServerProtect for NetApp 5.8" (以下、SPNAF)をご使用の場合は "SPNT" を "SPEMC" 、"SPNAF"へ置き換えください。

また、本事象はServerProtect for Storage 6.0 およびすでにMCPエージェントに移行した環境では発生しません。


(※注1)各製品のサポート期間・対象は製品のサポート終了案内およびTrend Micro Control Manager/Apex Centralにて管理可能な製品一覧に準じます。
(※注2)Patch 部分の種別につきましては以下の通りとなります。
 
  • SPNT : Patch 5 以上
  • SPEMC : Patch 2 以上
  • SPNAF : SP1 Patch 1 以上
(※注3)Control Manager エージェント(TMIベース)は、「アプリと機能」画面では「Trend Micro Control Manager Agent for ServerProtect」として表示されます。ServerProtectの管理コンソールの左側ペインの一番下に[Control Managerエージェントの設定]がある場合は、すでにMCPエージェント対応の環境です。(TMCMで管理されていない場合であっても設定画面は存在します。)
 

原因

TMCM ではTrend Micro Management Infrastructure サービスの動作に"mrf.exe"というファイルが利用されております。この"mrf.exe"は、以下のフォルダパスに格納されております。
※"Program Files (x86)" フォルダは64bit環境のOS限定となります。32bit環境の場合は以降"(x86)" を省いてください。
 

 C:\Program Files (x86)\Trend Micro\COMMON\TMI


上記エラーはSPNT5.8 Patch5 の適用の際に、上記 "mrf.exe" を以下のフォルダパスへリプレイスしてしまう事に起因しておりました。


【SPNT5.8 Patch5/SPEMC5.8 Patch2の場合】 
C:\Program Files (x86)\Trend Micro\COMMON\TMI\is_backup\filegroup100


【SPNAF5.8 SP1 Patch1 以降の場合】
C:\Program Files (x86)\Trend Micro\COMMON\TMI\backup*\
 

リプレイスの際にTMCM 側のパスにも "mrf.exe" は再設置されますが、再設置されるバージョンがTMCM 6.0 SP3 で配置されたバージョンと異なるため、TMCM 側で "mrf.exe" バージョンの差異が発生し、以後サービス起動が行えない状態となります。


また、付随してmrf.exe単体のみに限定せず、MRF関連のDLLファイルも全て再設置されます。
mrf.exeのみを復旧させ、サービスを起動できた状態でも、旧DLLファイルを使用することにより予期しない事象が発生する可能性がございます。
その為、MRF関連の以下DLLファイルにつきましても同様に置き換える必要がございます。

・MRF_CM.dll
・libTMI_DataMarshal.dll
・libMRF_Entity.dll
・libMRF_DM.dll
・libMRF_Common.dll
・libMRF_CM.dll
・libMRF_AP.dll
 

解決策

以下の手順を実施いただく事で改善される事を確認しております。
 
    1. 以下フォルダに "mrf.exe" とMRF関連DLLファイルが存在する事を確認し、バージョンが 1266 となっていることをご確認ください。


      【SPNT5.8 Patch5/SPEMC5.8 Patch2の場合】
      C:\Program Files (x86)\Trend Micro\COMMON\TMI\is_backup\filegroup100


      【SPNAF5.8 SP1 Patch1の場合】
      C:\Program Files (x86)\Trend Micro\COMMON\TMI\backup


      【確認ファイル】
      ・mrf.exe
      ・MRF_CM.dll
      ・libTMI_DataMarshal.dll
      ・libMRF_Entity.dll
      ・libMRF_DM.dll
      ・libMRF_Common.dll
      ・libMRF_CM.dll
      ・libMRF_AP.dll

      ※TMCMのインストールフォルダを変更している場合は該当の変更されたインストールフォルダよりご確認ください。
      ※バージョンはファイルを右クリックし、プロパティの [詳細] - [ファイルバージョン] よりご確認いただけます。
      ※"Program Files (x86)" フォルダは64bit環境のOS限定となります。32bit環境の場合は"(x86)" を省いてください。

       
    2. 1.で確認した "mrf.exe" 及びMRF関連DLLを全てコピーし、以下のフォルダのファイルへ上書きし置き換えてください。


      【SPNT5.8 Patch5 / SPEMC5.8 Patch2 / SPNAF5.8 SP1 Patch1共通】
      C:\Program Files (x86)\Trend Micro\COMMON\TMI


      【ファイルバージョン】
      旧 : ファイルバージョン 1.12.0.1156 (置き換え前)
      新 : ファイルバージョン 1.12.0.1266 (置き換え後)


      【置き換え対象ファイル】
      ・mrf.exe
      ・MRF_CM.dll
      ・libTMI_DataMarshal.dll
      ・libMRF_Entity.dll
      ・libMRF_DM.dll
      ・libMRF_Common.dll
      ・libMRF_CM.dll
      ・libMRF_AP.dll

       
    3. 「Trend Micro Management Infrastructure」サービスを起動し、
      サービスが起動される事をご確認ください。


      ※サーバのOS再起動は必要ございません。
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評価:
カテゴリ:
動作トラブル
Solution Id:
1113262
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