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dsa_control コマンドが error 111 / 101 で失敗する  

dsa_control コマンドが error 111 / 101 で失敗する

    • 更新日:
    • 29 Jul 2019
    • 製品/バージョン:
    • Trend Micro Deep Security 10.0
    • Trend Micro Deep Security 11.0
    • Trend Micro Deep Security 12.0
    • Trend Micro Deep Security 9.5
    • Trend Micro Deep Security 9.6
    • Trend Micro Deep Security as a Service All.All
    • OS:
    • Linux すべて
概要
 Linux版のDeep Security Agent (DSA) でコマンドラインのツール(dsa_control)を実行した所、以下のようなエラーが発生しました。
# /opt/ds_agent/dsa_control -a dsm://dsm: 4120/
Sending the command to the agent on the local machine...
Error: couldn't connect to 127.0.0.1:4118 (error 111: 接続を拒否されました)
Error: couldn't connect to ::1:4118 (error 101: ネットワークに届きません)
Unable to connect to the agent on the local machine.
 
この原因と対処法を教えてください。
詳細
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事象の発生条件

本事象は、以下の条件が全て揃った場合に発生する事が確認されています。
  1. 通信方向が[Agent/Applianceから開始]に設定されている
  2. Linuxで、IPv4 / IPv6 デュアルスタックの環境になっている
  3. IPv6のループバックインタフェースがカーネルパラメータによって無効化されている

原因

通信方向が[Agent/Applianceから開始]に設定されている場合、DSAは外部からの4118ポートへの接続を無効化しますが、dsa_controlコマンドからの命令を受け付けるためにループバックアドレスの待受けのみ実施します。
しかし、IPv6がシステムで無効化されていないにも関わらず、IPv6のループバックアドレスのみ無効化されていると、IPv6ループバックアドレスでの待受けに失敗した結果として本事象が発生します。

解決策

以下のコマンドを実行し、IPv6ループバックインタフェースを有効化します。

# sysctl kernel net.ipv6.conf.lo.disable_ipv6=0

# service network restart

# service ds_agent restart

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評価:
カテゴリ:
動作トラブル
Solution Id:
1114431
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