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Windows版 Deep Security Agent で、インストール直後のアップデートのみ失敗する  

Windows版 Deep Security Agent で、インストール直後のアップデートのみ失敗する

    • 更新日:
    • 7 Sep 2020
    • 製品/バージョン:
    • Cloud One - Endpoint and Workload Security All
    • Trend Micro Deep Security 10.0
    • Trend Micro Deep Security 11.0
    • Trend Micro Deep Security 12.0
    • Trend Micro Deep Security 20.0
    • Trend Micro Deep Security 9.6
    • Trend Micro Deep Security as a Service
    • OS:
    • Windows すべて
概要
 Windows版 Deep Security Agent (以下、DSA) をインストールした直後の最初のアップデートのみ、エラーが発生します。
この原因と対処法について教えてください。
詳細
Public

発生する事象と発生条件

Windows環境で、DSAをインストール・有効化した直後のアップデートのみ、以下のエラーが記録されます。

  • レベル: エラー
  • イベントID: 9017
  • イベント: 不正プログラム対策コンポーネントのアップデート失敗
  • 説明:
    不正プログラム対策コンポーネントのアップデート中に障害が発生しました。
     エラーコード: 11
     エラーメッセージ: AMSP error code (0xe0ff000b)

本事象は、以下の条件で発生する事が確認されております。

  • Windows版のDSAをmsiパッケージ単体もしくはインストールスクリプトからインストールした
  • インストール後の有効化と同時もしくは有効化処理の実行後、不正プログラム対策機能を有効化したポリシーを適用した

原因

本事象は、不正プログラム対策機能のプラグインをインストールした直後のアップデート処理が不正プログラム対策機能のサービスが起動する前に要求された結果として発生します。

しかし、実際のアップデートは不正プログラム対策機能のサービス起動後に実施され、一時的なエラーイベントとして記録されているものの、最終的にはアップデートに成功しますので、DSAの動作には影響がありません。

対処方法

本事象がインストール直後の初回のアップデート時にのみ報告され、エラーの発生直後にアップデートが成功した旨のイベントが記録されているようであれば、エラーは完全に無視できます。

インストール直後のエラー自体を回避したい場合、事前に不正プログラム対策機能のプラグインをインストールしておきます。詳細は以下の製品Q&Aを参照してください。

参考情報

Amazon EC2 のAutoscaling機能で自動生成されたインスタンス上で本事象が発生する場合、有効化済みのDSAを含むAMIを利用可能です。

有効化済みのDSAを含むAMIを新たなインスタンス上で自動有効化させるためには、Manager / Agent 共に9.6 Service Pack 1 Patch 1 Update 3 以上のビルドが必要です。詳しくはオンラインヘルプを参照してください(リンク先にてご利用バージョンを指定ください)。

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カテゴリ:
Troubleshoot
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