ビジネスサポートポータルアカウントでログイン
Linux版 Deep Security Agent における名前解決  

Linux版 Deep Security Agent における名前解決

    • 更新日:
    • 18 Oct 2019
    • 製品/バージョン:
    • Trend Micro Deep Security 10.0
    • Trend Micro Deep Security 11.0
    • Trend Micro Deep Security 12.0
    • Trend Micro Deep Security 9.5
    • Trend Micro Deep Security 9.6
    • OS:
    • Linux すべて
概要
DNSサーバのリプレースに伴い、/etc/resolv.conf を編集しました。
その後、curl、ping、nslookup 等のコマンドで Deep Security Manager (以降、DSM) の名前解決ができる事を確認しているにも関わらず、Deep Security Agent (DSA) ではDSMの名前解決ができないために通信不可能なエラーが繰り返し記録されます。
この原因と対処法を教えてください。
詳細
Public

原因

DSAでは独自に名前解決を行う機能を実装しておらず、Linux OS の NSS (Name Service Switch) に依存して名前解決を実施します。
NSSの仕組みでは、/etc/resolv.conf をプロセスの起動時にのみ読み込みます。
curl、ping、nslookup 等のコマンドでは、コマンドが実行される都度該当プロセスが一時的に起動しますので、常に最新の /etc/resolv.conf を読み出しているのに対して、DSAのようなサービスとして常駐しているプロセスでは、サービスを再起動しない限り、編集前の/etc/resolv.conf に従って名前解決を実施します。
ただし、/etc/hosts ファイルは名前解決を試みる都度読み込まれるため、サービスの再起動を実施しなくても最新の内容が反映されます。

 

対処法

/etc/resolv.conf の編集後は、DSAへその内容を反映させるためにds_agentサービスを再起動してください。
再起動の方法はDeep Security Manager/Deep Security Agentサービスの再起動/開始/停止方法」をご参照ください。
※Deep Security Agent再起動/停止/開始方法のLinuxの欄をご確認ください。
Premium
Internal
Partner
評価:
カテゴリ:
機能/仕様
Solution Id:
1118735
ご提案/ご意見
このソリューションはお役に立ちましたか?

フィードバックありがとうございました!


*こちらに技術的なご質問などをいただきましてもご返答する事ができません.

何卒ご了承いただきますようお願いいたします.


To help us improve the quality of this article, please leave your email here so we can clarify further your feedback, if neccessary:
We will not send you spam or share your email address.

*This form is automated system. General questions, technical, sales, and product-related issues submitted through this form will not be answered.


ユーザーガイド