概要
InterScan Messaging Security Suite(以下、InterScan MSS)/InterScan Messaging Security Virtual Appliance(以下、IMSVA)/Deep Discovery Email Inspector(以下、DDEI)において、配送先のメールサーバから"Helo command rejected: Host not found"といったエラーが返却されて、メールが配送できません。
対策について教えてください。
対策について教えてください。
詳細
原因
InterScan MSS/IMSVA/DDEIがメール配送時にSMTP HELO/EHLOコマンドで指定した自ホスト名が、配送先メールサーバ側で名前解決できなかったことが原因になります。
デフォルトでは、InterScan MSS/IMSVA/DDEIのOSのホスト名がSMTP HELO/EHLOコマンドで使用されます。
メールサーバによっては、「SMTPクライアントがSMTP HELO/EHLOコマンドで指定するホスト名」に対し、対応するAレコードまたはMXレコードがDNSから確認できない場合に受信拒否を行うことがあります。
なお、RFC 2821(Simple Mail Transfer Protocol) の 3.6 Domains では、SMTP EHLOコマンドで指定するホスト名が名前解決できることを求めています。
例として、postfixにはこのような機能があります。当該機能に抵触すると、以下のようなSMTP応答をSMTPクライアントに返却し、メールの受信を拒否いたします。
450 4.7.1 <ホスト名>: Helo command rejected: Host not found
対策
以下のような方法がございます。
1. InterScan MSS/IMSVA/DDEIのOSのホスト名が名前解決できるよう、DNSサーバ側で対応を行う。
対応するDNSサーバの管理者様等にご相談ください。
受信拒否を行っているメールサーバがInternet上のメールサーバの場合、ホスト名はInternet上で名前解決可能である必要があります。
2. InterScan MSS/IMSVA/DDEIがメール配送時にSMTP HELO/EHLOコマンドで指定する自ホスト名を、名前解決可能なホスト名に変更する。
製品毎の設定方法は以下の通りです。
2. InterScan MSS/IMSVA/DDEIがメール配送時にSMTP HELO/EHLOコマンドで指定する自ホスト名を、名前解決可能なホスト名に変更する。
製品毎の設定方法は以下の通りです。
変更したホスト名は、DNSサーバで名前解決ができる必要があります。変更とあわせて、対応するDNSサーバの管理者様等にご相談ください。
受信拒否を行っているメールサーバがInternet上のメールサーバの場合、ホスト名はInternet上で名前解決可能である必要があります。
InterScan MSS Linux版での設定(MTAとしてpostfixを使用)
例として、postfixの設定ファイルmain.cfの設定項目smtp_helo_nameで、HELO/EHLOコマンドで使用する自ホスト名のみを変更可能です。
設定および設定手順等の詳細は、ご利用のpostfixまたはOSのサポート窓口様等にご確認をお願いします。
InterScan MSS Linux版での設定(MTAとしてsendmailを使用)
例として、sendmailの設定ファイルsendmail.mcの設定項目define(`confHELO_NAME', `<ホスト名>')dnlで、HELO/EHLOコマンドで使用する自ホスト名のみを変更可能です。
設定および設定手順等の詳細は、ご利用のsendmailまたはOSのサポート窓口様等にご確認をお願いします。
InterScan MSS Windows版での設定
HELO/EHLOコマンドで使用する自ホスト名のみを変更可能です。
こちらのQAをご参照ください
IMSVAでの設定
HELO/EHLOコマンドで使用する自ホスト名のみを以下の手順で変更可能です。
1. IMSVAのLinuxコンソールにrootユーザでログイン
2. /opt/trend/imss/postfix/etc/postfix/main.cfに以下の設定行を追加
smtp_helo_name = (ホスト名)
3. 以下のコマンドを実行し、IMSVAのpostfixを再起動
# postfix reload
2. /opt/trend/imss/postfix/etc/postfix/main.cfに以下の設定行を追加
smtp_helo_name = (ホスト名)
3. 以下のコマンドを実行し、IMSVAのpostfixを再起動
# postfix reload
DDEIでの設定
DDEI管理画面の以下から、ホスト名の変更を行っていただく必要があります。
[管理] > [システム設定] > [ネットワーク] > "ホスト名"