ビジネスサポートポータルアカウントでログイン
Red Hat Enterprose Linux、CentOS 64ビット環境でServerProtect for Linux 3.0のインストール時に依存性チェックエラーが発生する  

Red Hat Enterprose Linux、CentOS 64ビット環境でServerProtect for Linux 3.0のインストール時に依存性チェックエラーが発生する

    • 更新日:
    • 25 Jul 2019
    • 製品/バージョン:
    • ServerProtect for Linux 3.0
    • OS:
    • Linux すべて
概要
Red Hat Enterprise Linux  (以下、RHEL)、CentOSのx86_64環境にServerProtect for Linux 3.0をインストール中、下記のような依存性エラーが発生します。
Installing ServerProtect for Linux:
Unpacking...
Installing rpm file...
エラー: Failed dependencies:
libatk-1.0.so.0 is needed by SProtectLinux-3.0-1171.x86_64
libexpat.so.0 is needed by SProtectLinux-3.0-1171.x86_64
libgdk_pixbuf-2.0.so.0 is needed by SProtectLinux-3.0-1171.x86_64
libgdk-x11-2.0.so.0 is needed by SProtectLinux-3.0-1171.x86_64
libglib-2.0.so.0 is needed by SProtectLinux-3.0-1171.x86_64
libgmodule-2.0.so.0 is needed by SProtectLinux-3.0-1171.x86_64
libgobject-2.0.so.0 is needed by SProtectLinux-3.0-1171.x86_64
libgtk-x11-2.0.so.0 is needed by SProtectLinux-3.0-1171.x86_64
libpango-1.0.so.0 is needed by SProtectLinux-3.0-1171.x86_64
libpangox-1.0.so.0 is needed by SProtectLinux-3.0-1171.x86_64
libpangoxft-1.0.so.0 is needed by SProtectLinux-3.0-1171.x86_64
libstdc++.so.6 is needed by SProtectLinux-3.0-1171.x86_64
libX11.so.6 is needed by SProtectLinux-3.0-1171.x86_64
libz.so.1 is needed by SProtectLinux-3.0-1171.x86_64
libuuid.so.1 is needed by SProtectLinux-3.0-1171.x86_64
libstdc++.so.6(GLIBCXX_3.4) is needed by SProtectLinux-3.0-1171.x86_64
詳細
Public

64ビット版のRHEL、CentOSを最小構成でインストールした場合、上記のような依存性エラーが発生します。
標準構成でインストールした場合では、32ビットアプリケーションの互換性を保つ目的で32ビットライブラリもインストールされますが、最小構成のインストールでは必要最小限のライブラリのみインストールされるため、ServerProtectに必要な上記の32ビットライブラリがインストールされません。

64ビット版のRHEL、CentOSを最小構成でインストールした環境では、ServerProtectをインストールする前に以下のRPMパッケージをインストールしてください。


■RHEL 4の例
libgcc-3.4.3-9.EL4.i386.rpm
compat-libstdc++-296-2.96-132.7.2.i386.rpm
libstdc++-3.4.3-9.EL4.i386.rpm
glib2-2.4.7-1.i386.rpm
atk-1.8.0-2.i386.rpm
e2fsprogs-1.35-11.6.EL4.i386.rpm
expat-1.95.7-4.i386.rpm
zlib-1.2.1.2-1.i386.rpm
freetype-2.1.9-1.i386.rpm
fontconfig-2.2.3-7.i386.rpm
xorg-x11-libs-6.8.1-23.EL.i386.rpm
xorg-x11-Mesa-libGL-6.8.1-23.EL.i386.rpm
pango-1.6.0-7.i386.rpm
libjpeg-6b-33.i386.rpm
libpng-1.2.7-1.i386.rpm
libtiff-3.6.1-7.i386.rpm
gtk2-2.4.13-12.i386.rpm

■RHEL 5の例
compat-libstdc++-296-2.96-138
glibc-2.5-18
e2fsprogs-libs-1.39-10.el5
krb5-libs-1.6.1-17.el5
e2fsprogs-libs-1.39-10.el5
libidn-0.6.5-1.1
openssl-0.9.8b-8.3.el5_0.2
zlib-1.2.3-3
libgcc-4.1.2-14.el5
keyutils-libs-1.2-1.el5
libsepol-1.15.2-1.el5
expat-1.95.8-8.2.1
curl-7.15.5-2.el5
glib2-2.12.3-2.fc6
libstdc++-4.1.2-14.el5
apr-1.2.7-11
atk-1.12.2-1.fc6
pango-1.14.9-3.el5
libX11-1.0.3-8.0.1.el5
cairo-1.2.4-2.el5
fontconfig-2.4.1-6.el5
libXext-1.0.1-2.1
libXrender-0.9.1-3.1
libXinerama-1.0.1-2.1
libXi-1.0.1-3.1
libXrandr-1.1.1-3.1
libXcursor-1.1.7-1.1
libXfixes-4.0.1-2.1
libXft-2.1.10-1.1
freetype-2.2.1-19.el5
libXau-1.0.1-3.1
libXdmcp-1.0.1-2.1
libpng-1.2.10-7.0.2

■CentOS 5の例
glibc-2.12-1.7.el6.i686
zlib-1.2.3-25.el6.i686
compat-libstdc++-296-2.96-144.el6.i686
libuuid-2.17.2-6.el6.i686
nss-softokn-freebl-3.12.7-1.1.el6.i686
libgcc-4.4.4-13.el6.i686
perl-5.10.1-115.el6.x86_64
perl-libs-5.10.1-115.el6.x86_64
perl-Module-Pluggable-3.90-115.el6.x86_64
perl-Pod-Escapes-1.04-115.el6.x86_64
perl-Pod-Simple-3.13-115.el6.x86_64
perl-version-0.77-115.el6.x86_64
gtk2-2.18.9-4.el6.i686
atk-1.28.0-2.el6.i686
pango-1.28.1-3.el6.i686
libX11-1.3-2.el6.i686
libXfixes-4.0.4-1.el6.i686
cairo-1.8.8-3.1.el6.i686
fontconfig-2.8.0-3.el6.i686
libXext-1.1-3.el6.i686
libXrender-0.9.5-1.el6.i686
libXinerama-1.1-1.el6.i686
libXi-1.3-3.el6.i686
libXrandr-1.3.0-4.el6.i686
libXcursor-1.1.10-2.el6.i686
libXcomposite-0.4.1-2.el6.i686
libXdamage-1.1.2-1.el6.i686
libpng-1.2.44-1.el6.i686
libXft-2.1.13-4.1.el6.i686
freetype-2.3.11-5.el6.i686
libxcb-1.5-1.el6.i686
pixman-0.16.6-1.el6.i686
libXau-1.0.5-1.el6.i686
libstdc++-4.4.4-13.el6.i686
libselinux-2.0.94-2.el6.i686
expat-2.0.1-9.1.el6.i686

■RHEL 6 の例
libgcc-4.4.4-13.el6.i686
glibc-2.12-1.25.el6.i686
nss-softokn-freebl-3.12.9-3.el6.i686
zlib-1.2.3-25.el6.i686
compat-libstdc++-296-2.96-144.el6.i686
libuuid-2.17.2-6.el6.i686
libstdc++-4.4.4-13.el6.i686
apr-1.3.9-3.el6.x86_64
perl-libs-5.10.1-119.el6.x86_64
perl-5.10.1-119.el6.x86_64
perl-version-0.77-119.el6.x86_64
perl-Pod-Simple-3.13-119.el6.x86_64
perl-Module-Pluggable-3.90-119.el6.x86_64
perl-Pod-Escapes-1.04-119.el6.x86_64

■CentOS 6の例:
libgcc-4.4.6-4.el6
nss-softokn-freebl-3.12.9-11.el6.i686
glibc-2.12-1.80.el6.i686
zlib-1.2.3-27.el6.i686
compat-libstdc++-296-2.96-144.el6.i686
libuuid-2.17.2-7.el6.i686
libstdc++-4.4.6-4.el6.i686
glibc-2.12-1.80.el6.i686
apr-1.3.9-3.el6_1.2.i686

また、以下のパッケージもインストールする必要があります。
---
perl-libs-5.10.1-127.el6.x86_64
perl-5.10.1-127.el6.x86_64
perl-version-0.77-127.el6.x86_64
perl-Pod-Simple-3.13-127.el6.x86_64
perl-Module-Pluggable-3.90-127.el6.x86_64
perl-Pod-Escapes-1.04-127.el6.x86_64
---

■RHEL 7の例:

以下のperl関連のパッケージをインストールする必要があります。

---
perl-Sys-Syslog-0.33-3.el7.x86_64
perl-5.16.3-283.el7.x86_64
perl-HTTP-Tiny-0.033-3.el7.x86_64
perl-parent-1:0.225-244.el7.x86_64
perl-Pod-Perldoc-3.20-4.el7.x86_64
perl-podlators-2.5.1-3.el7.x86_64
perl-Pod-Escapes-1:1.04-283.el7.x86_64
perl-Text-ParseWords-1:1.04-283.el7.x86_64
perl-Encode-2.51-7.el7.x86_64
perl-Pod-Usage-1.63-3.el7.x86_64
perl-libs-4:5.16.3-283.el7.x86_64
perl-macros-4:5.16.3-283.el7.x86_64
perl-constant-1.27-2.el7.x86_64
perl-Carp-1.26-244.el7.x86_64
perl-Exporter-5.68-3.el7.x86_64
perl-Scalar-List-Utils-1.27-248.el7.x86_64
perl-Filter-1.49-3.el7.x86_64
perl-Socket-2.010-3.el7.x86_64
perl-threads-1.87-4.el7.x86_64
perl-Storable-2.45-3.el7.x86_64
perl-Time-Local-1.2300-2.el7.x86_64
perl-File-Path-2.09-2.el7.x86_64
perl-File-Temp-0.23.01-3.el7.x86_64
perl-PathTools-3.40-5.el7.x86_64
perl-threads-shared-1.43-6.el7.x86_64
perl-Pod-Simple-1:3.28-4.el7.x86_64
perl-Getopt-Long-2.40-2.el7.x86_64
---

glibc-2.17-55.el7.x86_64
zlib-1.2.7-13.el7.x86_64
compat-libstdc++-33-3.2.3-71.el7.x86_64  *1
libuuid-2.23.2-16.el7.x86_64
nss-softokn-freebl-3.15.4-2.el7.x86_64
libgcc-4.8.2-16.el7.x86_64

*1: このパッケージは、RHEL7インストールDVDに含まれておりません。 Red Hat Network またはyumコマンドから入手してください。


注意:

・上記は全て各ディストーションの初期のインストールパッケージに含まれるrpmです。パッケージ内容によっては各rpmパッケージのバージョンが異なる可能性があります。

Premium
Internal
評価:
カテゴリ:
インストール; 動作トラブル
Solution Id:
1302795
ご提案/ご意見
このソリューションはお役に立ちましたか?

フィードバックありがとうございました!

いただいたご提案/ご意見に関して、トレンドマイクロから詳細確認のため、Eメールを送付させていただく場合がありますので、Eメールアドレスを入力してください:
入力いただいたEメールアドレスはソリューション改善のためだけに使用いたします.

*こちらに技術的なご質問などをいただきましてもご返答する事ができません.

何卒ご了承いただきますようお願いいたします.


To help us improve the quality of this article, please leave your email here so we can clarify further your feedback, if neccessary:
We will not send you spam or share your email address.

*This form is automated system. General questions, technical, sales, and product-related issues submitted through this form will not be answered.


ユーザーガイド