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侵入防御イベント:Invalid UTF8 Encoding / 無効なUTF8の符号化  

侵入防御イベント:Invalid UTF8 Encoding / 無効なUTF8の符号化

    • 更新日:
    • 13 Mar 2020
    • 製品/バージョン:
    • Trend Micro Deep Security 10.0
    • Trend Micro Deep Security 11.0
    • Trend Micro Deep Security 12.0
    • Trend Micro Deep Security 9.5
    • Trend Micro Deep Security 9.6
    • OS:
    • Linux すべて
    • Virtual Appliance すべて
    • Windows すべて
概要
Trend Micro Deep Security (以下、DS) の侵入防御イベントに「Invalid UTF8 Encoding / 無効なUTF8の符号化」が記録されます。このイベントが発生した場合の対応方法を教えてください。
詳細
Public

原因

DSは、HTTPリクエスト中の文字列の文字コードのエンコーディングに「UTF-8」または「Latin-1」が利用できます。(初期設定はLatin-1です)

UTF-8を設定している状態で、UTF-8 として正しくデコードできないデータが送信された場合、不正なデータを送信する事による攻撃の可能性があるため、このイベントが発生します。

ただし、Web サイトが UTF-8 以外の文字コード (Shift-JIS や EUC-JP など) を使用している場合は、それらの文字コードで正常なデータが送信された場合にも、このイベントが発生します。

回避策

Web サイトが UTF-8 以外の文字コードを使用していて、この検出を回避したい場合は、以下の設定を行ってください。

  1. [ポリシー] > [共通オブジェクト] > [ルール] > [侵入防御ルール] 画面で「1000128 - HTTP Protocol Decoding」ルールのプロパティを開きます。
  2. [設定]タブを選択し、「Assume URI uses following encoding method:」から「Latin-1」を選択します。
  3. 「OK」ボタンをクリックします。
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評価:
カテゴリ:
操作方法/設定
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