Sign In with your
Trend Micro Account
Need Help?
Need More Help?

Create a technical support case if you need further support.

Safe Search setting in InterScan Web Security Virtual Appliance (IWSVA) does not work

    • Updated:
    • 18 Dec 2015
    • Product/Version:
    • InterScan Web Security Virtual Appliance 5.6
    • InterScan Web Security Virtual Appliance 6.0
    • InterScan Web Security Virtual Appliance 6.5
    • Platform:
    • N/A N/A
Summary

Even with the Safe Search set to “Strict” in IWSVA, you still can change your Safe Search option in the Google search pages and search for inappropriate content.

When you look at the verbose log, you can find log entries similar to the following:

2010/03/31 14:30:46 GMT+01:00 <4513:4524> CheckSafeSearchPolicy:: [images.google.co.uk/images] not a supported search engine or search request.

Details
Public

This issue occurs because the regional Google search URLs are not included in the IWSVA default setting files.

To resolve the issue:

  1. Create a back up of the /var/iwss/safesearch_engine.xml file and then open it with vi.
  2. Find the “EngineList” session of Google:

    <EngineList>
    <Engine name="www.google.com/search>
    <Engine name="images.google.com/images"/>
    <Engine name="video.google.com/video"/>
    <Engine name="www.google.cn/search>
    <Engine name="www.google.com.au/search>
    <Engine name="images.google.com.au/images"/>
    <Engine name="video.google.com.au/video"/>
    <Engine name="www.google.co.jp/search>
    <Engine name="images.google.co.jp/images"/>
    <Engine name="video.google.co.jp/video"/>
    </EngineList>

  3. Append the regional Google search URLs to the list. For example, for Google UK, we add the following lines:

    Engine name="images.google.co.uk/images"
    Engine name="www.google.co.uk/search"
    Engine name="video.google.co.uk/video"

    After the changes have been made,  the “EngineList” session should look like below:

    <EngineList>
    <Engine name="www.google.com/search>
    <Engine name="images.google.com/images"/>
    <Engine name="video.google.com/video"/>
    <Engine name="www.google.cn/search>
    <Engine name="www.google.com.au/search>
    <Engine name="images.google.com.au/images"/>
    <Engine name="video.google.com.au/video"/>
    <Engine name="www.google.co.jp/search>
    <Engine name="images.google.co.jp/images"/>
    <Engine name="video.google.co.jp/video"/>
    <Engine name="images.google.co.uk/images"/>
    <Engine name="www.google.co.uk/search>
    <Engine name="video.google.co.uk/video"/>
    </EngineList>

  4. Save the changes and then restart the HTTP service:

    #/var/iwss/S99ISproxy stop
    #/var/iwss/S99ISproxy start

Safe Search should now work without issue.

Premium
Internal
Rating:
Category:
Configure; Troubleshoot
Solution Id:
1055643
Feedback
Did this article help you?

Thank you for your feedback!

To help us improve the quality of this article, please leave your email here so we can clarify further your feedback, if neccessary:
We will not send you spam or share your email address.

*This form is automated system. General questions, technical, sales, and product-related issues submitted through this form will not be answered.

If you need additional help, you may try to contact the support team. Contact Support


To help us improve the quality of this article, please leave your email here so we can clarify further your feedback, if neccessary:
We will not send you spam or share your email address.

*This form is automated system. General questions, technical, sales, and product-related issues submitted through this form will not be answered.


Need More Help?

Create a technical support case if you need further support.