Sign In with your
Trend Micro Account
Need Help?
Need More Help?

Create a technical support case if you need further support.

System requirements for Deep Security 9.0

    • Updated:
    • 18 Feb 2015
    • Product/Version:
    • Deep Security 9.0
    • Platform:
    • N/A N/A
Summary

Know the minimum requirements for installing Deep Security 9.0.

Details
Public
  • Memory: 8GB, which includes:
    • 4GB heap memory
    • 1.5GB JVM overhead
    • 2GB operating system overhead
  • Disk Space: 1.5GB (5GB recommended)
  • Operating System: Microsoft Windows 2012 (64-bit), Windows Server 2008 (64-bit), Windows Server 2008 R2 (64-bit), Windows 2003 Server SP2 (64-bit), Red Hat Linux 5/6 (64-bit)
  • Database: Oracle 11g, Oracle 10g, Microsoft SQL Server 2012 (all Service Packs), Microsoft SQL Server 2008 (all Service Packs)
  • Web Browser: Firefox 12+, Internet Explorer 8.x, Internet Explorer 9.x, Internet Explorer 10.x, Chrome 20+, Safari 5+.
    Cookies must be enabled in all browsers.
  • Memory:
    • With Anti-Malware protection: 512MB
    • Without Anti-Malware protection: 128MB
  • Disk Space: 500MB (1GB recommended if Anti-Malware protection is enabled)
  • Windows: Windows 8 (32-bit and 64-bit), Windows Server 2012 (64-bit), Windows 7 (32-bit and 64-bit), Windows Server 2008 R2 (64-bit), Windows Server 2008 (32-bit and 64-bit), Windows Vista (32-bit and 64-bit), Windows Server 2003 SP1 32-bit and 64-bit) with "Windows Server 2003 Scalable Networking Pack" patch, Windows Server 2003 SP2 (32-bit and 64-bit), Windows Server 2003 R2 SP2 (32-bit and 64-bit), Windows XP (32-bit and 64-bit)
  • Solaris: Solaris 9, 10, 11 (64-bit Sparc), Solaris 10 and 11, (64-bit x86)
  • Linux: Red Hat 5 (32-bit and 64-bit), Red Hat 6 (32-bit and 64-bit), Oracle Linux 5 (32-bit and 64-bit), Oracle Linux 6 (32-bit and 64-bit), SuSE 10 (32-bit and 64-bit), SuSE 11 (32-bit and 64-bit), Ubuntu 10.04 LTS (64-bit), Ubuntu 12.04 LTS (64-bit), CentOS 5 (32-bit and 64-bit), CentOS 6 (32-bit and 64-bit), Amazon Linux (32-bit and 64-bit).
    (Agent-based Anti-Malware is not supported on 32-bit versions of Linux)
  • AIX: AIX 5.3, 6.1
    The AIX Agents do not support Anti-Malware or Web Reputation protection.
  • HP-UX: 11i v3 (11.31)
    The HP-UX Agents only support Integrity Monitoring and Log Inspection.
 
Windows Agents running on Windows XP or Windows 2003 will not function in an IPv6 environment.
 
  • Memory: 512MB
  • Disk Space: 500MB (1GB recommended if Anti-Malware protection is enabled)
  • Windows: Windows 8 (32-bit and 64-bit), Windows 7 (32-bit and 64-bit), Windows Server 2012 (64-bit), Windows Server 2008 (32-bit and 64-bit), Windows Server 2008 R2 (64-bit), Windows Vista (32-bit and 64-bit), Windows Server 2003 SP2 (32-bit and 64-bit), Windows Server 2003 R2 (32-bit and 64-bit), Windows XP (32-bit and 64-bit)
  • Linux: Red Hat 5 (64-bit), Red Hat 6 (64-bit), CentOS 5 (64-bit), CentOS 6 (64-bit)
  • Memory: 2GB (Memory requirements can vary depending on the number of VMs being protected.
  • Disk Space: 20GB
  • Operating System: VMware vCenter 5.x, and ESXi 5.x
  • Additional VMware Utilities: VMware Tools, VMware vShield Manager 5.x, VMware vShield Endpoint Security 5.x (ESXi5 patch ESXi500-201109001 or later for vShield Endpoint Driver)
  • VMware Endpoint Protection supported guest platforms: Windows 7 (32-bit and 64-bit), Windows Vista (32-bit and 64-bit), Windows XP SP2 (32-bit and 64-bit), Windows Server 2003 SP2 (32-bit and 64-bit), Windows Server 2003 R2 (32-bit and 64-bit), Windows Server 2008 (32-bit and 64-bit), Windows Server 2008 R2 (64-bit).
    For the latest list of supported guest platforms, see your VMware documentation.

In addition to the ESXi standard system requirements, the following specifications must be met:

  • CPU: 64-bit, Intel-VT present and enabled in BIOS
  • Supported vSwitch: standard vSwitch or 3rd party vSwitch – Cisco Nexus 1000v

TPM hypervisor integrity monitoring requires ESXi 5.1, and is not supported on ESXi 5.0.

 
A virtualized ESXi environment (hypervisor running as a VM) is not supported.
 

Windows: Windows 8 (32-bit and 64-bit), Windows 7 (32-bit and 64-bit), Windows Server 2012 (64-bit, non-core), Windows Server 2008 R2 (64-bit), Windows Server 2008 (32-bit and 64-bit), Windows Vista (32-bit and 64-bit), Windows Server 2003 Sp1 32-bit and 64-bit) with "Windows Server 2003 Scalable Networking Pack" patch, Windows Server 2003 SP2 (32-bit and 64-bit), Windows Server 2003 R2 SP2 (32-bit and 64-bit), Windows XP (32-bit and 64-bit)

 
On VMs protected by a Virtual Appliance, the Anti-Malware module must be licensed and enabled on the VM for the Deep Security Notifier to display information.
 
Premium
Internal
Rating:
Category:
Install
Solution Id:
1097542
Feedback
Did this article help you?

Thank you for your feedback!

To help us improve the quality of this article, please leave your email here so we can clarify further your feedback, if neccessary:
We will not send you spam or share your email address.

*This form is automated system. General questions, technical, sales, and product-related issues submitted through this form will not be answered.

If you need additional help, you may try to contact the support team. Contact Support


To help us improve the quality of this article, please leave your email here so we can clarify further your feedback, if neccessary:
We will not send you spam or share your email address.

*This form is automated system. General questions, technical, sales, and product-related issues submitted through this form will not be answered.


Need More Help?

Create a technical support case if you need further support.