Sign In with your
Trend Micro Account
Need Help?
Need More Help?

Create a technical support case if you need further support.

System requirements for Deep Security 9.5

    • Updated:
    • 15 Sep 2017
    • Product/Version:
    • Deep Security 9.5
    • Platform:
    • N/A N/A
Summary

Know the minimum requirements for installing Deep Security 9.5

Details
Public
  • Memory: 8GB, which includes:
    • 4GB heap memory
    • 1.5GB JVM overhead
    • 2GB operating system overhead
  • Disk Space: 1.5GB (5GB recommended)
  • Operating System: Windows Server 2012 (64-bit), Windows Server 2012 R2 (64-bit), Windows Server 2008 (64-bit), Windows Server 2008 R2 (64-bit), Windows 2003 Server SP2 (64-bit), Windows 2003 Server R2 (64-bit), Red Hat Linux 5/6 (64-bit)
  • Database: Oracle 11g, Oracle 11g Express, Oracle 10g, Oracle 10g Express, Microsoft SQL Server 2014, Microsoft SQL Server 2014 Express, Microsoft SQL Server 2012, Microsoft SQL Server 2012 Express, Microsoft SQL Server 2008, Microsoft SQL Server 2008 Express, Microsoft SQL Server 2008 R2, Microsoft SQL Server 2008 R2 Express
  • Web Browser: Firefox 24+, Internet Explorer 9.x, Internet Explorer 10.x, Internet Explorer 11.x, Chrome 33+, Safari 6+. (Cookies enabled)
  • Monitor: 1024 x 768 resolution at 256 colors or higher
  • Memory
    • With Anti-Malware protection: 512MB
    • Without Anti-Malware protection: 128MB
  • Disk Space
    • With Anti-Malware protection: 1GB
    • Without Anti-Malware protection: 500MB
    • With Relay functionality enabled: 8GB
  • Windows: Windows Server 2012 R2 (64-bit), Windows Server 2012 (64-bit), Windows 8.1 (32-bit and 64-bit), Windows 8 (32-bit and 64-bit), Windows 7 (32-bit and 64-bit), Windows Server 2008 R2 (64-bit), Windows Server 2008 (32-bit and 64-bit), Windows Vista (32-bit and 64-bit), Windows Server 2003 SP1 (32-bit and 64-bit) with patch "Windows Server 2003 Scalable Networking Pack", Windows Server 2003 SP2 (32-bit and 64-bit), Windows Server 2003 R2 SP2 (32-bit and 64-bit), Windows XP (32-bit and 64-bit)
    • With Relay functionality enabled: All Windows versions (64-bit only)
  • Linux: Red Hat 5 (32-bit and 64-bit), Red Hat 6 (32-bit and 64-bit), Oracle Linux 5 (32-bit and 64-bit), Oracle Linux 6 (32-bit and 64-bit), CentOS 5 (32-bit and 64-bit), CentOS 6 (32-bit and 64-bit), SuSE 10 SP3 and SP4 (32-bit and 64-bit), SuSE 11 SP1, SP2, and SP3 (32-bit and 64-bit), CloudLinux 5 (32-bit and 64-bit), CloudLinux 6 (32-bit and 64-bit)
    • With Relay functionality enabled: All Linux verions (64-bit only)
  • Memory: 4GB (Memory requirements can vary depending on the number of VMs being protected)
  • Disk Space: 20GB
  • VMware Environment
    • NSX Environment: VMware vCenter 5.5, with ESXi 5.5
    • vShield Environment: VMware vCenter 5.0, 5.1, or 5.5, with ESXi 5.0, 5.1, or 5.5
  • Additional VMware Utilities:
    • NSX Environment: VMware Tools 9.4, VMware vCenter Server Appliance 5.5, VMware NSX Manager 6.1
    • vShield Environment: VMware Tools, VMware vShield Manager 5.0, 5.1, or 5.5, VMware vShield Endpoint Security 5.0, 5.1, or 5.5 (ESXi5 patch ESXi500-201109001 or later for vShield Endpoint Driver)
  • VMware Endpoint Protection supported guest platforms:
    • Windows: Windows Server 2012 R2 (64-bit), Windows Server 2012 (64-bit), Windows 8.1 (32-bit and 64-bit), Windows 8 (32-bit and 64-bit), Windows 7 (32-bit and 64-bit), Windows Vista (32-bit and 64-bit), Windows Server 2003 SP2 R2 (32-bit and 64-bit), Windows Server 2003 SP2 (32-bit and 64-bit), Windows XP SP2 (32-bit and 64-bit)
    • Linux: Red Hat 5 (32-bit and 64-bit), Red Hat 6 (32-bit and 64-bit), Oracle Linux 5 (32-bit and 64-bit), Oracle Linux 6 (32-bit and 64-bit), CentOS 5 (32-bit and 64-bit), CentOS 6 32-bit and 64-bit), SuSE 10 (32-bit and 64-bit), SuSE 11 (32-bit and 64-bit)

In addition to the ESXi standard system requirements, the following specifications must be met:

  • CPU: 64-bit, Intel-VT or AMD-V present and enabled in BIOS
  • Supported vSwitches:
    • NSX: vSphere Distributed Switch (vDS)
    • vShield: vSphere Standard Switch (vSS) or third party vSwitch (Cisco Nexus 1000v)

For Windows:

  • Windows Server 2012 R2 (64-bit)
  • Windows Server 2012 (64-bit)
  • Windows 8.1 (32-bit and 64-bit)
  • Windows 8 (32-bit and 64-bit)
  • Windows 7 (32-bit and 64-bit)
  • Windows Server 2008 R2 (64-bit)
  • Windows Server 2008 (32-bit and 64-bit)
  • Windows Vista (32-bit and 64-bit)
  • Windows Server 2003 SP2

For more information (such as database sizing), refer to Deep Security 9.5 Best Practice Guide.

Premium
Internal
Rating:
Category:
Install
Solution Id:
1104744
Feedback
Did this article help you?

Thank you for your feedback!

To help us improve the quality of this article, please leave your email here so we can clarify further your feedback, if neccessary:
We will not send you spam or share your email address.

*This form is automated system. General questions, technical, sales, and product-related issues submitted through this form will not be answered.

If you need additional help, you may try to contact the support team. Contact Support


To help us improve the quality of this article, please leave your email here so we can clarify further your feedback, if neccessary:
We will not send you spam or share your email address.

*This form is automated system. General questions, technical, sales, and product-related issues submitted through this form will not be answered.