Sign In with your
Trend Micro Account
Need Help?
Need More Help?

Create a technical support case if you need further support.

Pre-checking the dependencies of Deep Security Agent before installation

    • Updated:
    • 9 May 2019
    • Product/Version:
    • Deep Security 10.0
    • Deep Security 10.1
    • Deep Security 10.2
    • Deep Security 10.3
    • Deep Security 11.0
    • Deep Security 11.1
    • Deep Security 11.2
    • Deep Security 11.3
    • Deep Security 9.6
    • Platform:
    • N/A N/A
Summary

Prior to installation, customers need to check if the operating system is lacking of any dependencies required by Deep Security Agent.

Details
Public

Below are the required dependencies for each operating system:

An external tool, such as depends.exe, can check if there is any DLL file missing.

Below are the dependencies for Linux:

  • linux-vdso.so.1 (0x00007ffc86953000)
  • /opt/ds_agent/lib/libwx_baseu-2.9.so.4 (0x00007f584ac58000)
  • /opt/ds_agent/lib/dsa_core.so (0x00007f584a7d7000)
  • /opt/ds_agent/lib/libslb.so (0x00007f584a5cb000)
  • /opt/ds_agent/lib/liblua.so (0x00007f584a399000)
  • /lib64/libdl.so.2 (0x0000003c87200000)
  • /opt/ds_agent/lib/libcrypto.so.1.0.0 (0x00007f5849f50000)
  • /opt/ds_agent/lib/libssl.so.1.0.0 (0x00007f5849ce0000)
  • /usr/lib64/libstdc++.so.6 (0x0000003c92a00000)
  • /lib64/libm.so.6 (0x0000003c88200000)
  • /lib64/libgcc_s.so.1 (0x0000003c92600000)
  • /lib64/libpthread.so.0 (0x0000003c87a00000)
  • /lib64/libc.so.6 (0x0000003c87600000)
  • /lib64/libz.so.1 (0x0000003c88600000)
  • /lib64/ld-linux-x86-64.so.2 (0x0000003c86e00000)
  • /lib64/libacl.so.1 (0x0000003c93600000)
  • /opt/ds_agent/lib/libwxsqlite.so (0x00007f5849aaf000)
  • /opt/ds_agent/lib/libsqlite.so (0x00007f5849825000)
  • /opt/ds_agent/lib/libexpat.so.1 (0x00007f58495fb000)
  • /lib64/libattr.so.1 (0x0000003c97200000)

Unix / SUSE Linux

Usually, you should be able to install Deep Security Agent using the existing packages in SUSE Linux. In case you encounter any dependency issues, follow the procedure below to check those necessary dependency packages.

  1. Install Deep Security Agent.

    # rpm -i Agent-Core-SuSE_11-11.0.0-716.x86_64.rpm

    Host platform - NAME="SLES"
    Starting ds_agent: done

  2. Check the ds_agent process using ps command.

    # ps -ef | grep ds
    root 21978 1 0 07:28 ? 00:00:00 /opt/ds_agent/ds_agent -w /var/opt/ds_agent -b -i -e /opt/ds_agent/ext
    root 21980 21978 1 07:28 ? 00:00:00 /opt/ds_agent/ds_agent -w /var/opt/ds_agent -b -i -e /opt/ds_agent/ext
    root 21997 21891 0 07:28 pts/2 00:00:00 grep ds

  3. Run the commands below to check dependencies.

    # (rpm -qR ds_agent | cut -d' ' -f1 | grep -v '^rpmlib(' | while read c; do rpm -q --whatprovides $c; done) | sort -u
    # ldd -n /opt/ds_agent/ds_agent

Below are sample outputs:

# (rpm -qR ds_agent | cut -d' ' -f1 | grep -v '^rpmlib(' | while read c; do rpm -q --whatprovides $c; done) | sort -u
bash-3.2-147.27.35
glibc-2.11.3-17.84.1
libacl-2.2.47-30.36.1
libgcc_s1-4.8.3+r212056-2.17
libstdc++6-4.8.3+r212056-2.17
# ldd /opt/ds_agent/ds_agent
linux-vdso.so.1 => (0x00007ffc40712000)
libwx_baseu-2.9.so.4 => /opt/ds_agent/lib/libwx_baseu-2.9.so.4 (0x00007f41658c2000)
dsa_core.so => /opt/ds_agent/lib/dsa_core.so (0x00007f4165439000)
libslb.so => /opt/ds_agent/lib/libslb.so (0x00007f416522c000)
liblua.so => /opt/ds_agent/lib/liblua.so (0x00007f4164ffb000)
libdl.so.2 => /lib64/libdl.so.2 (0x00007f4164dec000)
libcrypto.so.1.0.0 => /opt/ds_agent/lib/libcrypto.so.1.0.0 (0x00007f41649b1000)
libssl.so.1.0.0 => /opt/ds_agent/lib/libssl.so.1.0.0 (0x00007f416473e000)
libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007f4164435000)
libm.so.6 => /lib64/libm.so.6 (0x00007f41641bc000)
libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007f4163fa5000)
libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f4163d87000)
libc.so.6 => /lib64/libc.so.6 (0x00007f4163a0b000)
libz.so.1 => /lib64/libz.so.1 (0x00007f41637f5000)
/lib64/ld-linux-x86-64.so.2 (0x00007f4165d79000)
libacl.so.1 => /lib64/libacl.so.1 (0x00007f41635ec000)
libwxsqlite.so => /opt/ds_agent/lib/libwxsqlite.so (0x00007f41633b3000)
libsqlite.so => /opt/ds_agent/lib/libsqlite.so (0x00007f41630fe000)
libexpat.so.1 => /opt/ds_agent/lib/libexpat.so.1 (0x00007f4162ed2000)
libattr.so.1 => /lib64/libattr.so.1 (0x00007f4162ccd000)

The ds_agent needs the following:

  • /opt/ds_agent/lib/librpc.so
  • /opt/ds_agent/lib/dsa_core.so
  • /opt/ds_agent/lib/libfingerprint.so
  • /opt/ds_agent/lib/libwx_base-2.8.a
  • /opt/ds_agent/lib/libsqlite.so
  • /opt/ds_agent/lib/libssl.so
  • /opt/ds_agent/lib/libcrypto.so
  • /usr/lib/libpthread.a(shr_xpg5_64.o)
  • /opt/ds_agent/lib/libz.so
  • /opt/ds_agent/lib/liblua.so
  • /opt/ds_agent/lib/libstdc++.a(libstdc++.so.6)
  • /opt/ds_agent/lib/libgcc_s.a(shr.o)
  • /usr/lib/libc.a(shr_64.o)
  • /unix
  • /opt/ds_agent/lib/libexpat.a(libexpat.so.0)
  • /opt/ds_agent/lib/libslb.so
  • /usr/lib/libiconv.a(shr4_64.o)
  • /usr/lib/libpthreads.a(shr_xpg5_64.o)
  • /usr/lib/libcrypt.a(shr_64.o)

Solaris 11 will perform some dependency check based on the publisher before the program installation.

To disable the publisher, run any of the following commands:

  • pkg unset-publisher solaris
  • pkg set-publisher --disable solaris

Note that Solaris 11 requires gcc-45-runtime. If IPS function is required, OS also needs the ksh package as it provides the ksh93 package, which provides the /usr/bin/sh shell.

Below are the necessary dependencies:

  • linux-vdso.so.1 (0x00007fff301ff000)
  • /opt/ds_agent/./lib/libwx_baseu_net-2.9.so.4 (0x00007f24cd439000)
  • /opt/ds_agent/./lib/libwx_baseu-2.9.so.4 (0x00007f24ccf81000)
  • /opt/ds_agent/./lib/dsa_core.so (0x00007f24ccb1e000)
  • /opt/ds_agent/./lib/libslb.so (0x00007f24cc911000)
  • /usr/lib/libstdc++.so.6 (0x00007f24cc5f3000)
  • /lib/libm.so.6 (0x00007f24cc370000)
  • /lib/libgcc_s.so.1 (0x00007f24cc15a000)
  • /lib/libpthread.so.0 (0x00007f24cbf3e000)
  • /lib/libc.so.6 (0x00007f24cbbdb000)
  • /opt/ds_agent/./lib/libssl.so.0.9.8 (0x00007f24cb985000)
  • /opt/ds_agent/./lib/libcrypto.so.0.9.8 (0x00007f24cb5f3000)
  • /opt/ds_agent/./lib/liblua.so (0x00007f24cb3c2000)
  • /usr/lib/libz.so.1 (0x00007f24cb1ab000)
  • /lib/libdl.so.2 (0x00007f24cafa7000)
  • /lib64/ld-linux-x86-64.so.2 (0x00007f24cd63d000)
  • /lib/libacl.so.1 (0x00007f24cad9f000)
  • /usr/lib/libapt-pkg.so.4.10 (0x00007f24caa99000)
  • /opt/ds_agent/./lib/libwxsqlite.so (0x00007f24ca869000)
  • /opt/ds_agent/./lib/libsqlite.so (0x00007f24ca5e0000)
  • /opt/ds_agent/./lib/libexpat.so.0 (0x00007f24ca3b8000)
  • /lib/libattr.so.1 (0x00007f24ca1b3000)
  • /lib/libutil.so.1 (0x00007f24c9fb0000)
  • /opt/ds_agent/./lib/libwx_baseu-2.9.so.4 (0x00007f4b94e44000)
  • /opt/ds_agent/./lib/libsqlite.so (0x00007f4b94bbc000)
  • /opt/ds_agent/./lib/dsa_core.so (0x00007f4b94759000)
  • /opt/ds_agent/./lib/libdsam.so (0x00007f4b9452e000)
  • /opt/ds_agent/./lib/libssl.so.0.9.8 (0x00007f4b942d8000)
  • /opt/ds_agent/./lib/libscancache.so (0x00007f4b93d3a000)
  • /opt/ds_agent/./lib/libvmpdcommon.so (0x00007f4b93b31000)
  • /opt/ds_agent/./lib/libglib-2.0.so.0 (0x00007f4b9381d000)
  • /opt/ds_agent/./lib/libgthread-2.0.so.0 (0x00007f4b933f3000)
  • /lib/librt.so.1 (0x00007f4b91319000)
Premium
Internal
Rating:
Category:
Configure
Solution Id:
1119383
Feedback
Did this article help you?

Thank you for your feedback!

To help us improve the quality of this article, please leave your email here so we can clarify further your feedback, if neccessary:
We will not send you spam or share your email address.

*This form is automated system. General questions, technical, sales, and product-related issues submitted through this form will not be answered.

If you need additional help, you may try to contact the support team. Contact Support

To help us improve the quality of this article, please leave your email here so we can clarify further your feedback, if neccessary:
We will not send you spam or share your email address.

*This form is automated system. General questions, technical, sales, and product-related issues submitted through this form will not be answered.