Sign In with your
Trend Micro Account
Need Help?
Need More Help?

Create a technical support case if you need further support.

SECURITY BULLETIN: Directory Traversal Vulnerability in Trend Micro Apex One, OfficeScan and Worry-Free Business Security

    • Updated:
    • 9 Apr 2019
    • Product/Version:
    • Apex One All.All
    • Apex One as a Service All.All
    • OfficeScan 11.All
    • OfficeScan as a Service All.All
    • OfficeScan XG.All
    • Worry-Free Business Security Standard/Advanced 10.All
    • Worry-Free Business Security Standard/Advanced 9.0
    • Worry-Free Business Security Standard/Advanced 9.5
    • Platform:
    • Windows 10
    • Windows 2012 Server
    • Windows 2016 Server
    • Windows 2019 Server
    • Windows 7 32-Bit
    • Windows 7 64-Bit
    • Windows 8 32-Bit
    • Windows 8 64-Bit
Summary
Release Date: April 3, 2019
CVE Identifier(s): CVE-2019-9489
Platform(s): Windows
CVSSv3: 7.5 AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N 
Severity Rating(s): High

Trend Micro has released new Critical Patches (CPs) for Apex One, OfficeScan XG, OfficeScan 11.0 SP1, and Worry-Free Business Security versions 9.0 SP3, 9.5 and 10.  These CPs resolve a directory traversal vulnerability which could allow a potential attacker to modify arbitrary files on the Apex One, OfficeScan or Worry-Free consoles. 

Details
Public

Affected Version(s)

ProductAffected Version(s)PlatformLanguage(s)
Apex One as a ServiceBefore March 27, 2019 Maintenance ReleaseWindowsEnglish
Apex OneB1066 and belowWindowsEnglish
OfficeScanXG (Version 12.0)WindowsEnglish
11.0 SP1WindowsEnglish
Worry-Free Business Security10.0WindowsEnglish
9.5WindowsEnglish
9.0 SP3WindowsEnglish

Solution

Trend Micro has released the following solutions to address the issue:

ProductUpdated versionNotesPlatformAvailability
Apex One as a ServiceMarch 2019 Monthly Maintenance ReleaseN/AWindowsMarch 27
Apex One*Apex One Build 1071 (repack)ReadmeWindowsAvailable Now
Apex One CP1101ReadmeWindows
Available Now
OfficeScanXG SP1 CP5338ReadmeWindows
Available Now
XG (non SP1) CP1933ReadmeWindows
Available Now
11.0 SP1 CP6598ReadmeWindows
Available Now
Worry-Free Business Security10.0 Patch B1531ReadmeWindows
Available Now
9.5 CP1487ReadmeWindows
Available Now
9.0 SP3 CP4394ReadmeWindows
Available Now

*Some enhancements to the patch code were made after Apex One was originally made available for download (GA) on Trend Micro's Download Center. Therefore, there are two available solutions for Apex One customers - Critical Patch (CP) 1101 for those that have already deployed the orignial GA version (build 1066) or the entire deployment package has been repackaged as build 1071. In addition, customers who have build 1066 already installed should use CP1101, since the the build 1071 repack will not install over the 1066 build. The build 1071 repack should be used for new installations only.

These are the minimum version(s) of the patch and/or builds required to address the issue. Trend Micro highly encourages customers to obtain the latest version of the product if there is a newer one available than the one listed in this bulletin.

Customers are encouraged to visit Trend Micro’s Download Center to obtain prerequisite software (such as Service Packs) before applying any of the solutions above.

Vulnerability Details

This update resolves a directory traversal vulnerability in Trend Micro Apex One, OfficeScan and Worry-Free Business Security that, if exploited, could allow an attacker to modify arbitrary files on the product's management console.

Due to the seriousness of this vulnerability, customers are highly encouraged to update to the latest build as soon as possible.

Mitigating Factors

Exploiting these type of vulnerabilities generally require that an attacker has access (physical or remote) to a vulnerable machine. In addition to timely application of patches and updated solutions, customers are also advised to review remote access to critical systems and ensure policies and perimeter security is up-to-date - including limiting access to the server that the product's management console is loaded on.

In addition, customers who use Trend Micro Deep Security also have protection with rule 1009608, which was released on April 3, 2019, as part of DSRU19-018.

However, even though an exploit may require several specific conditions to be met, Trend Micro strongly encourages customers to update to the latest builds as soon as possible.

External Reference(s)

CVE-2019-9489
Premium
Internal
Rating:
Category:
Upgrade; Update
Solution Id:
1122250
Feedback
Did this article help you?

Thank you for your feedback!

To help us improve the quality of this article, please leave your email here so we can clarify further your feedback, if neccessary:
We will not send you spam or share your email address.

*This form is automated system. General questions, technical, sales, and product-related issues submitted through this form will not be answered.

If you need additional help, you may try to contact the support team. Contact Support

To help us improve the quality of this article, please leave your email here so we can clarify further your feedback, if neccessary:
We will not send you spam or share your email address.

*This form is automated system. General questions, technical, sales, and product-related issues submitted through this form will not be answered.