Views: 19

Symptom

Occasionally, you may experience an issue where the Vision One console will display "SMS Consoles (0)" under Network Intrusion Prevention even after successfully generating the enrollment token and connecting the SMS to Vision One in the SMS Web Gui. 

 

 

In the SMS Web Interface, you may also see something similar to this:

 

 

You may also see errors in the SMS logs similar to this:

[VisionOneDevicesInfoUploaderRunner] Error uploading device inventory to Vision One: com.tpt.server.pub.visionone.VisionOneServiceException: Failed to upload device inventory (CODE = 8802303):
Following parameters doesn’t have valid type: smsApiKey

 

Root Cause

During the initial setup of the connection, either the API Key for the SuperUser account was not generated at all or there was an issue synchronizing the key between the devices.

 

Resolution

In the SMS Java Client, you would want to locate the API Key field located at:

Admin > Authentication and Authorization > Users > SuperUser > Edit > Authentication

 

Click the Regenerate API Key button and the connection issue should resolve itself.