Sign In with your
Trend Micro Account
Need Help?
Need More Help?

Create a technical support case if you need further support.

Protocol for setting useHTTPSocketAdatpter and ous.ini is inconsistent in OfficeScan/Apex One

    • Updated:
    • 30 Jun 2020
    • Product/Version:
    • Apex One 2019
    • OfficeScan XG
    • Platform:
Summary

The Security Agent sometimes updates successfully and sometimes fails because of inconsistent protocol when setting useHTTPSocketAdatpter and ous.ini.

Details
Public
  • Network Topology:

    Server:192.168.84.15
    Agent:192.168.84.10
    UA:192.168.84.18

  • OUS setting:

    OUS1 = 192.168.84.10,192.168.84.10,,http://192.168.84.18:21112/activeupdate

  • When the server is set to use ASE=1 and useSocketHttpAdapter=0, it uses https:

    Server,ofcscan.ini
    ASE=1
    useSocketHttpAdapter=0

  • Check the UA Registry:

    [HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\TrendMicro\PC-cillinNTCorp\CurrentVersion]
    "ASE"=dword:00000001
    "UseSocketHTTPAdapter"=dword:00000000

    It also uses HTTPS.

  • Check the agent's ous.ini:

    OUS1 = 192.168.84.10,192.168.84.10,,http://192.168.84.18:21112/activeupdate

    When the update source is set to use HTTP but the agent and UA use https, the agent update will fail.

  • Check the database dbo.TBL_CLIENT_INFO:

    STATE_FLAG2 =0 in the database means use HTTP
    STATE_FLAG2 =2 in the database means use HTTPS

    Sometimes it is STATE_FLAG2 =0 and sometimes it is STATE_FLAG2 =2.

    TBL_CLIENT_INFO

To make sure that the protocol agent used is consistent with the server, modify the UpdateSource from HTTP to HTTPs:

  1. Access the web console by going to Updates > Agents > Update Source.
  2. Modify the update source from HTTP to https, and then deploy it to the agents:

    https://192.168.84.18:21112/activeupdate

    In the server's ofcscan.ini, the setting is as shown below:

    ASE=1
    useSocketHttpAdapter=0

  3. Update the agent and then check the agent's ous.ini.

    The update source is set with https:

    OUS1 = 192.168.84.10,192.168.84.10,,https://192.168.84.18:21112/activeupdate

  4. In the agent's registry, check "ASE" and "useSocketHttpAdapter".
     
    If useSocketHttpAdapter does not exist, that's normal as its default value is 0.

    [HKEY_LOCAL_MACHINE\SOFTWARE\TrendMicro\PC-cillinNTCorp\CurrentVersion]
    "ASE"=dword:00000001
    "useSocketHttpAdapter"=dword:00000000

  5. After a while, check the database dbo.TBL_CLIENT_INFO, STATE_FLAG2 =2.
Premium
Internal
Partner
Rating:
Category:
Configure; Troubleshoot; Update
Solution Id:
000257062
Feedback
Did this article help you?

Thank you for your feedback!

To help us improve the quality of this article, please leave your email here so we can clarify further your feedback, if neccessary:
We will not send you spam or share your email address.

*This form is automated system. General questions, technical, sales, and product-related issues submitted through this form will not be answered.

If you need additional help, you may try to contact the support team. Contact Support

To help us improve the quality of this article, please leave your email here so we can clarify further your feedback, if neccessary:
We will not send you spam or share your email address.

*This form is automated system. General questions, technical, sales, and product-related issues submitted through this form will not be answered.