Sign In with your
Trend Micro Account
Need Help?
Need More Help?

Create a technical support case if you need further support.

"An error in the Plug-in Service program occurred..." error message appears when installing Apex One (Mac) plug-in

    • Updated:
    • 19 Aug 2020
    • Product/Version:
    • Apex One (Mac)
    • Platform:
Summary

When installing installing Apex One (Mac) plug-in, the following error message is encountered:

An error in the Plug-in Service program occurred. Unable to install the Apex One (Max) server. The product's database cannot be installed. Contact your support provider for help in resolving this issue.

Root Cause Analysis

Error can be seen in the following log files:

  • In C:\TMSM_DBTool.log:
    2019-10-15 10:45:39 109 [1] ERROR TMSMDBTool - System.ArgumentException: Format of the initialization 
        string does not conform to specification starting at index 84. at System.Data.Common.DbConnectionOptions.GetKeyValuePair
        (String connectionString, Int32 currentPosition, StringBuilder buffer, Boolean useOdbcRules, 
        String& keyname, String& keyvalue)
    
  • In C:\TMSM_PreInstall.log
    [10-15-2019 10:45:39][DebugLevel-Error]---Install TMSM objects to OSCE DB failed 
    (D:\TMSM-Server-OnPremise_3.5\installshield\TMSforMacintosh\Script Files\Setup.Rul, 495) 
    
    [10-15-2019 10:45:39][DebugLevel-Info]---FreshInstallDB() out (D:\TMSM-Server-OnPremise_3.5\installshield\TMSforMacintosh\Script Files\Setup.Rul, 561)
    

Based on the log files, there is a connection string error being used by SQL Server to connect to the database. The password being used to connect with the database has some special characters (Ex. [] {}() , ; ? * ! @.), which are incompatible with the connection string.

Details
Public

To resolve the issue, change password of the account being used to connect to the SQL Server, and make sure that it does not contain special characters. (Ex. [] {}() , ; ?' * !" @.).

More information about this issue can be found in this Microsoft article: Format of the initialization string does not conform to specification starting at index.

Premium
Internal
Partner
Rating:
Category:
Troubleshoot
Solution Id:
000262664
Feedback
Did this article help you?

Thank you for your feedback!

To help us improve the quality of this article, please leave your email here so we can clarify further your feedback, if neccessary:
We will not send you spam or share your email address.

*This form is automated system. General questions, technical, sales, and product-related issues submitted through this form will not be answered.

If you need additional help, you may try to contact the support team. Contact Support

To help us improve the quality of this article, please leave your email here so we can clarify further your feedback, if neccessary:
We will not send you spam or share your email address.

*This form is automated system. General questions, technical, sales, and product-related issues submitted through this form will not be answered.