Sign In with your
Trend Micro Account
Need Help?
Need More Help?

Create a technical support case if you need further support.

Deep Security Support for Windows 10

    • Updated:
    • 12 Jul 2019
    • Product/Version:
    • Deep Security 10.0
    • Deep Security 10.1
    • Deep Security 10.2
    • Deep Security 10.3
    • Deep Security 11.0
    • Deep Security 11.1
    • Deep Security 11.2
    • Deep Security 11.3
    • Deep Security 12.0
    • Deep Security 9.6
    • Platform:
    • N/A N/A
Summary

This article contains the list of Deep Security supported versions related to Windows 10 updates.

Details
Public
Agent Solution (Deep Security Agent)
Windows 10
Version
12.0 (LTS)11.3 (FR)11.2 (FR)11.1 (FR)11.0 (LTS)10.3 (FR)10.2 (FR)10.1 (FR)10.0 (LTS)9.6 SP1 (LTS)
1607
1703 (RS2)10.0 Update 1 (10.0.0-2240) or later9.6 SP1 Update 16 (9.6.2-8397) or later
1709 (RS3)10.0 Update 9 (10.0.0-2775) or later
1803 (RS4)11.0 Update 1 (11.0.0-326) or later10.0 Update 16 (10.0.0.3186) or later
1809 (RS5)11.0 Update 4 (11.0.0-514) or later10.0 Update 16 (10.0.0.3186) or later
1903 (RS6)TBDTBD

 

Agentless Solution (Deep Security Virtual Agent)
Windows 10
Version
12.0 (LTS)11.3 (FR)11.2 (FR)11.1 (FR)11.0 (LTS)10.3 (FR)10.2 (FR)10.1 (FR)10.0 (LTS)9.6 SP1 (LTS)
1607-----
1703 (RS2)
1709 (RS3)---
1803 (RS4)---
1809 (RS5)------
1903 (RS6)-------
 
NSX-T is supported in Deep Security 12.0 and later. The checkmark (✔) in Deep Security 12.0 means the Windows 10 versions are supported by both NSX-v and NSX-T.

Below are some additional notes:

  1. Items marked with "-" are not yet tested.
  2. For general agentless solution supportability of the latest Windows 10 version, refer to VMware Tools and Guest Introspection.
  3. While Deep Security Virtual Appliance compatibility does not rely on VMware Horizon, the supportability of the latest Windows 10 version on VDI agentless also relies on VMware Horizon Agent.
  4. Microsoft will end its support for Windows 10 version 18 months after its availability. Please refer to Windows lifecycle fact sheet. Deep Security may not fully support it because of the limited support from Microsoft.
Premium
Internal
Rating:
Category:
Configure
Solution Id:
1119919
Feedback
Did this article help you?

Thank you for your feedback!

To help us improve the quality of this article, please leave your email here so we can clarify further your feedback, if neccessary:
We will not send you spam or share your email address.

*This form is automated system. General questions, technical, sales, and product-related issues submitted through this form will not be answered.

If you need additional help, you may try to contact the support team. Contact Support

To help us improve the quality of this article, please leave your email here so we can clarify further your feedback, if neccessary:
We will not send you spam or share your email address.

*This form is automated system. General questions, technical, sales, and product-related issues submitted through this form will not be answered.