Sign In with your
Trend Micro Account
Need Help?
Need More Help?

Create a technical support case if you need further support.

Digital Vaccine #9005

    • Updated:
    • 26 Sep 2017
    • Product/Version:
    • TippingPoint Digital Vaccine
    • Platform:
Summary
Digital Vaccine #9005      September 26, 2017
Details
Public
Thank you for subscribing to Digital Vaccine updates brought to you by Trend Micro™ TippingPoint DVLabs.

New content is now available at the Threat Management Center (TMC): https://tmc.tippingpoint.com

SMS customers can update the Digital Vaccine through the SMS client. From the top line menu, you can open the "File > Download Digital Vaccine from TMC" menu item to detect and load the latest update.
 
System Requirements
The 2.5.2 DV will run on IPS devices with TOS v2.5.2 to TOS v3.1.x.
The 3.2.0 DV will run on IPS devices with TOS v3.2.0 and above,  all NGFW and all TPS systems.
The 4.0.0 DV will only run on the Virtual Threat Protection System (vTPS) appliance.
Please note that vTPS does not currently support pre-disclosed ZDI filters.
 
The Digital Vaccine can be manually downloaded from the following URLs:
https://tmc.tippingpoint.com/TMC/ViewPackage?parentFolderId=digital_vaccines&contentId=SIG_2.5.2_9005.pkg
https://tmc.tippingpoint.com/TMC/ViewPackage?parentFolderId=digital_vaccines&contentId=SIG_3.2.0_9005.pkg
https://tmc.tippingpoint.com/TMC/ViewPackage?parentFolderId=vsa_dv&contentId=SIG_VTPS_4.0.0_9005.pkg

Update Details

Table of Contents
--------------------------

Filters
 New Filters
 Modified Filters (logic changes)
 Modified Filters (metadata changes only)
 Removed Filters

Filters
----------------
 New Filters:


    29079: FTP: FTP Service on Non-Standard Ports
      - IPS Version: 3.1.3 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Category: Security Policy
      - Severity: Low
      - Description: This filter detects the usage of FTP over a port other than 21.
      - Deployment: Not enabled by default in any deployment.

    29518: HTTP: Content-Disposition Filename Extension Does Not Match Payload File Type
      - IPS Version: 3.1.3 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Category: Security Policy
      - Severity: Low
      - Description: This filter attempts to detect a mismatch between the filename file extension of the HTTP Content-Disposition response header with an attachment parameter and the payload file type.
      - Deployment: Not enabled by default in any deployment.

    29634: ZDI-CAN-5035: Zero Day Initiative Vulnerability (Adobe Acrobat Pro DC)
      - IPS Version: 3.2.0 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: Not available.
      - Requires: IPS N-Platform, NX-Platform, NGFW, or TPS models.
      - Category: Exploits
      - Severity: Critical
      - Description: This filter provides protection against exploitation of a zero-day vulnerability affecting Adobe Acrobat Pro DC.
      - Deployments:
        - Deployment: Security-Optimized (Block / Notify)

    29635: ZDI-CAN-5036: Zero Day Initiative Vulnerability (Adobe Acrobat Pro DC)
      - IPS Version: 3.2.0 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: Not available.
      - Requires: IPS N-Platform, NX-Platform, NGFW, or TPS models.
      - Category: Exploits
      - Severity: Critical
      - Description: This filter provides protection against exploitation of a zero-day vulnerability affecting Adobe Acrobat Pro DC.
      - Deployments:
        - Deployment: Security-Optimized (Block / Notify)

    29636: ZDI-CAN-5037: Zero Day Initiative Vulnerability (Adobe Acrobat Pro DC)
      - IPS Version: 3.2.0 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: Not available.
      - Requires: IPS N-Platform, NX-Platform, NGFW, or TPS models.
      - Category: Exploits
      - Severity: Critical
      - Description: This filter provides protection against exploitation of a zero-day vulnerability affecting Adobe Acrobat Pro DC.
      - Deployments:
        - Deployment: Security-Optimized (Block / Notify)

    29637: ZDI-CAN-5038: Zero Day Initiative Vulnerability (Adobe Acrobat Pro DC)
      - IPS Version: 3.2.0 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: Not available.
      - Requires: IPS N-Platform, NX-Platform, NGFW, or TPS models.
      - Category: Exploits
      - Severity: Critical
      - Description: This filter provides protection against exploitation of a zero-day vulnerability affecting Adobe Acrobat Pro DC.
      - Deployments:
        - Deployment: Security-Optimized (Block / Notify)

    29638: ZDI-CAN-5039: Zero Day Initiative Vulnerability (Adobe Acrobat Pro DC)
      - IPS Version: 3.2.0 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: Not available.
      - Requires: IPS N-Platform, NX-Platform, NGFW, or TPS models.
      - Category: Exploits
      - Severity: Critical
      - Description: This filter provides protection against exploitation of a zero-day vulnerability affecting Adobe Acrobat Pro DC.
      - Deployments:
        - Deployment: Security-Optimized (Block / Notify)

    29639: ZDI-CAN-5040: Zero Day Initiative Vulnerability (Adobe Acrobat Pro DC)
      - IPS Version: 3.2.0 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: Not available.
      - Requires: IPS N-Platform, NX-Platform, NGFW, or TPS models.
      - Category: Exploits
      - Severity: Critical
      - Description: This filter provides protection against exploitation of a zero-day vulnerability affecting Adobe Acrobat Pro DC.
      - Deployments:
        - Deployment: Security-Optimized (Block / Notify)

    29640: ZDI-CAN-5041: Zero Day Initiative Vulnerability (Cisco Webex)
      - IPS Version: 3.2.0 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: Not available.
      - Requires: IPS N-Platform, NX-Platform, NGFW, or TPS models.
      - Category: Vulnerabilities
      - Severity: Critical
      - Description: This filter provides protection against exploitation of a zero-day vulnerability affecting Cisco Webex.
      - Deployments:
        - Deployment: Security-Optimized (Block / Notify)

    29665: HTTP: Apache Server OPTIONS Information Disclosure Vulnerability (Optionsbleed)
      - IPS Version: 3.1.3 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Category: Vulnerabilities
      - Severity: Critical
      - Description: This filter detects an attempt to exploit an information disclosure vulnerability in Apache server.
      - Deployment: Not enabled by default in any deployment.
      - References:
        - Common Vulnerabilities and Exposures: CVE-2017-9798

  Modified Filters (logic changes):
    * = Enabled in Default deployments

    * 2270: BitTorrent: Peer-to-Peer Communications
      - IPS Version: 1.0.0 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Description updated.
      - Detection logic updated.
      - NGFW Application Groups updated.
      - Deployments updated and are now:
        - Deployment: Default (Block / Notify)

    * 28287: ZDI-CAN-4759-4761: Zero Day Initiative Vulnerability (HPE Intelligent Management Center)
      - IPS Version: 3.2.0 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: Not available.
      - Requires: IPS N-Platform, NX-Platform, NGFW, or TPS models.
      - Detection logic updated.

    29064: SIP: Digium Asterisk SIP CSeq Buffer Overflow Vulnerability
      - IPS Version: 3.1.3 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Detection logic updated.

  Modified Filters (metadata changes only):
    * = Enabled in Default deployments

    * 8229: HTTP: Internet Explorer Memory Corruption (ZDI-09-039)
      - IPS Version: 1.0.0 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Description updated.

    * 8241: HTTP: Apple Webkit dir Attribute Exploit (ZDI-09-033)
      - IPS Version: 1.0.0 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Description updated.

    * 9342: HTTP: Sun Java Runtime Environment MIDI File Handling Memory Corruption (ZDI-10-053)
      - IPS Version: 1.0.0 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Name changed from "9342: HTTP: Sun Java Runtime Environment MIDI File Handling Memory Corruption (ZDI-10-034)".
      - Description updated.

    10529: HTTP: HP OpenView Network Node Manager Buffer Overflow Vulnerability (ZDI-11-010/ZDI-11-348)
      - IPS Version: 1.0.0 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Name changed from "10529: HTTP: HP OpenView Network Node Manager Buffer Overflow Vulnerability (ZDI-10-010/ZDI-11-348)".

    * 10851: HTTP: Oracle Java Applet Clipboard Injection Remote Code Execution Vulnerability (ZDI-11-083)
      - IPS Version: 1.0.0 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Description updated.
      - Vulnerability references updated.

    11247: TFTP: Novell ZENworks Heap Overflow (ZDI-11-089)
      - IPS Version: 1.0.0 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Name changed from "11247: TFTP: Novell ZENworks Heap Overflow (ZDI-10-284)".
      - Description updated.

    12664: HTTP: Oracle Outside In XPM Image Processing Stack Buffer Overflow (ZDI-12-150)
      - IPS Version: 1.0.0 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Description updated.

    13161: HTTP: Microsoft Internet Explorer execCommand Use-After-Free Vulnerability (ZDI-13-221)
      - IPS Version: 1.0.0 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Description updated.

    * 13656: HTTP: PineApp Mail-SeCure Export Log Command Injection Vulnerability (ZDI-13-187)
      - IPS Version: 1.0.0 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Name changed from "13656: HTTP: PineApp Mail-SeCure Export Log Command Injection Vulnerability (ZDI-13-184)".

    * 21148: RPC: Advantech WebAccess webvrpcs DrawSrv.dll BwBuildPath Buffer Overflow Vulnerability (ZDI-16-093)
      - IPS Version: 3.2.2 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Name changed from "21148: RPC: Advantech WebAccess webvrpcs DrawSrv.dll BwBuildPath Buffer Overflow Vulnerability (ZDI-16-085)".
      - Description updated.

    * 22679: HTTP:Apple OS X PDF Parsing Code Execution Vulnerability (ZDI-16-201)
      - IPS Version: 3.1.3 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Name changed from "22679: HTTP:Apple OS X PDF Parsing Code Execution Vulnerability (ZDI-15-201)".

    * 22680: HTTP: Adobe Reader DC XFA prePrint Use-After-Free Vulnerability (ZDI-16-294)
      - IPS Version: 3.1.3 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Vulnerability references updated.

    * 22750: HTTP: Adobe Acrobat Pro DC Close Page Action Use-After-Free Vulnerability (ZDI-16-298)
      - IPS Version: 3.1.3 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Vulnerability references updated.

    22812: HTTP: Adobe Reader DC XFA preOpen Event Use-After-Free Vulnerability (ZDI-16-297)
      - IPS Version: 3.1.3 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Vulnerability references updated.

    22813: HTTP: Adobe Reader DC XFA Page prePrint Event Use-After-Free Vulnerability (ZDI-16-296)
      - IPS Version: 3.1.3 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Vulnerability references updated.

    28226: HTTP: Microsoft Windows Bitmap Parsing Information Disclosure Vulnerability (ZDI-17-724)
      - IPS Version: 3.1.3 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Name changed from "28226: HTTP: Microsoft Windows Bitmap Parsing Information Disclosure Vulnerability".
      - Description updated.
      - Vulnerability references updated.

    * 28736: HTTP: Microsoft Windows PDF Library JPEG2000 Memory Corruption Vulnerability (ZDI-17-728)
      - IPS Version: 3.1.3 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Name changed from "28736: HTTP: Microsoft Windows PDF Library JPEG2000 Memory Corruption Vulnerability".
      - Description updated.
      - Vulnerability references updated.

    * 28737: HTTP: Microsoft Office Word Bidirectional Text Information Disclosure Vulnerability (ZDI-17-734)
      - IPS Version: 3.1.3 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Name changed from "28737: HTTP: Microsoft Office Word Bidirectional Text Information Disclosure Vulnerability".
      - Description updated.
      - Vulnerability references updated.

    * 28981: HTTP: Microsoft Edge Scripting Engine Memory Corruption Vulnerability (ZDI-17-731)
      - IPS Version: 3.1.3 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Name changed from "28981: HTTP: Microsoft Edge Scripting Engine Memory Corruption Vulnerability".
      - Description updated.
      - Vulnerability references updated.

    * 29153: HTTP: Microsoft Office Powerpoint Use-After-Free Vulnerability (ZDI-17-732)
      - IPS Version: 3.1.3 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Name changed from "29153: HTTP: Microsoft Office Powerpoint Use-After-Free Vulnerability".
      - Description updated.
      - Vulnerability references updated.

    29569: HTTP: Microsoft Windows win32k Out-of-Bounds Write Vulnerability
      - IPS Version: 3.1.3 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Description updated.
      - Vulnerability references updated.

    * 29574: HTTP: Microsoft Windows PDF Memory Corruption Vulnerability
      - IPS Version: 3.1.3 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Description updated.
      - Vulnerability references updated.

    * 29576: HTTP: Microsoft Internet Explorer and Edge WeakMap Memory Corruption Vulnerability (ZDI-17-726)
      - IPS Version: 3.1.3 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Name changed from "29576: HTTP: Microsoft Internet Explorer and Edge WeakMap Memory Corruption Vulnerability".
      - Description updated.
      - Vulnerability references updated.

    * 29579: HTTP: Microsoft Edge SelectionRange Memory Corruption Vulnerability
      - IPS Version: 3.1.3 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Description updated.
      - Vulnerability references updated.

    29599: HTTP: Microsoft Office Excel .xlsb Buffer Overflow Vulnerability (ZDI-17-727)
      - IPS Version: 3.1.3 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Name changed from "29599: HTTP: Microsoft Office Excel .xlsb Buffer Overflow Vulnerability".
      - Description updated.
      - Vulnerability references updated.

  Removed Filters:  None
  
   
Top of the Page
Premium
Internal
Rating:
Category:
Configure; Troubleshoot; Deploy
Solution Id:
TP000090871
Feedback
Did this article help you?

Thank you for your feedback!

To help us improve the quality of this article, please leave your email here so we can clarify further your feedback, if neccessary:
We will not send you spam or share your email address.

*This form is automated system. General questions, technical, sales, and product-related issues submitted through this form will not be answered.

If you need additional help, you may try to contact the support team. Contact Support


To help us improve the quality of this article, please leave your email here so we can clarify further your feedback, if neccessary:
We will not send you spam or share your email address.

*This form is automated system. General questions, technical, sales, and product-related issues submitted through this form will not be answered.