Sign In with your
Trend Micro Account
Need Help?
Need More Help?

Create a technical support case if you need further support.

Digital Vaccine #9377

    • Updated:
    • Product/Version:
    • TippingPoint Digital Vaccine
    • Platform:
Summary
Digital Vaccine #9377      January 14, 2020
Details
Public
Thank you for subscribing to Digital Vaccine updates brought to you by Trend Micro™ TippingPoint DVLabs.

New content is now available at the Threat Management Center (TMC): https://tmc.tippingpoint.com.

SMS customers can update the Digital Vaccine through the SMS client. From the top-line menu, you can open the "File > Download Digital Vaccine from TMC" menu item to detect and load the latest update.
 
System Requirements
The 3.2.0 DV will run on IPS devices with TOS v3.2.0 and above, all NGFW and all TPS systems. The 4.0.0 DV will only run on the Virtual Threat Protection System (vTPS) appliance. Please note that vTPS does not currently support pre-disclosed ZDI filters.
 
Microsoft Security Bulletins
This DV includes coverage for the Microsoft vulnerabilities released on or before January 14, 2020. The following table maps TippingPoint filters to the Microsoft CVEs.
CVEFilterStatus
CVE-2020-0601 Under Investigation
CVE-2020-0602 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0603 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0605 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0606 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0607 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0608 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-060936882 
CVE-2020-061036883 
CVE-2020-0611 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0612 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0613 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0614 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0615 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0616 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0617 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0620 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0621 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0622 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0623 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0624 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0625 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0626 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0627 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0628 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0629 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0630 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0631 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0632 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0633 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0634 Requires Local Exploitation
CVE-2020-0634 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0635 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0636 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0637 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0638 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0639 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0640 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0641 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0642 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0643 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0644 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0645 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0646 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0647 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0650 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0651 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0652*36696 
CVE-2020-0653 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0654 Vendor Deemed Reproducibility or Exploitation Unlikely
CVE-2020-0656 Vendor Deemed Reproducibility or Exploitation Unlikely
Filters marked with * shipped prior to this DV, providing zero-day protection.
 
The Digital Vaccine can be manually downloaded from the following URLs:
https://tmc.tippingpoint.com/TMC/ViewPackage?parentFolderId=digital_vaccines&contentId=SIG_3.2.0_9377.pkg
https://tmc.tippingpoint.com/TMC/ViewPackage?parentFolderId=vsa_dv&contentId=SIG_VTPS_4.0.0_9377.pkg

Update Details

Table of Contents
--------------------------

Filters
New Filters - 12
Modified Filters (logic changes) - 11
Modified Filters (metadata changes only) - 2
Removed Filters - 0

Filters
----------------
New Filters:
    36865: HTTP: FusionPBX Operator Panel exec.php Command Injection Vulnerability
      - IPS Version: 3.6.2 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Category: Vulnerabilities
      - Severity: Critical
      - Description: This filter detects an attempt to exploit a command injection vulnerability in FusionPBX.
      - Deployments:
        - Deployment: Security-Optimized (Block / Notify)
      - References:
        - Common Vulnerabilities and Exposures: CVE-2019-11409 CVSS 6.5
      - Classification: Vulnerability - Input Validation (Command injection, XSS, SQL injection, etc)
      - Protocol: HTTP
      - Platform: Multi-Platform Server Application or Service

    36872: HTTP: CoDeSys V3 CmpWebServer And CmpWebServerHandler Buffer Overflow Vulnerability
      - IPS Version: 3.6.2 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Category: Vulnerabilities
      - Severity: Critical
      - Description: This filter detects an attempt to exploit a buffer overflow vulnerability in CoDeSys V3.
      - Deployments:
        - Deployment: Security-Optimized (Block / Notify)
      - References:
        - Common Vulnerabilities and Exposures: CVE-2019-18858 CVSS 7.5
      - Classification: Vulnerability - Buffer/Heap Overflow
      - Protocol: HTTP
      - Platform: Windows Server Application or Service

    36876: HTTP: Citrix Application Delivery Controller (ADC) Directory Traversal Vulnerability
      - IPS Version: 3.6.2 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Category: Vulnerabilities
      - Severity: Critical
      - Description: This filter detects an attempt to exploit a directory traversal vulnerability in Citrix Application Delivery Controller (ADC).
      - Deployments:
        - Deployment: Security-Optimized (Block / Notify)
      - References:
        - Common Vulnerabilities and Exposures: CVE-2019-19781
      - Classification: Vulnerability - Input Validation (Command injection, XSS, SQL injection, etc)
      - Protocol: HTTP
      - Platform: Multi-Platform Server Application or Service

    36879: HTTP: Multiple File Uploads In Single multipart/form-data Request
      - IPS Version: 3.6.2 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Category: Security Policy
      - Severity: Moderate
      - Description: This filter detects an attempt to upload multiple files within a multipart/form-data request.
      - Deployment: Not enabled by default in any deployment.
      - References:
        - Common Vulnerabilities and Exposures: CVE-2019-5096
      - Classification: Vulnerability - Input Validation (Command injection, XSS, SQL injection, etc)
      - Protocol: HTTP
      - Platform: Other Server Application or Service

    36880: HTTP: ThinkPHP NoneCms PHP Injection Vulnerability
      - IPS Version: 3.6.2 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Category: Vulnerabilities
      - Severity: Critical
      - Description: This filter detects an attempt to exploit a PHP injection vulnerability in the ThinkPHP NoneCms library.
      - Deployments:
        - Deployment: Security-Optimized (Block / Notify)
      - References:
        - Common Vulnerabilities and Exposures: CVE-2018-20062
      - Classification: Vulnerability - Input Validation (Command injection, XSS, SQL injection, etc)
      - Protocol: HTTP
      - Platform: Multi-Platform Server Application or Service

    36882: UDP: Microsoft Remote Desktop Gateway Code Execution Vulnerability
      - IPS Version: 3.6.2 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Category: Exploits
      - Severity: Critical
      - Description: This filter detects an attempt to exploit a code execution vulnerability in Microsoft Remote Desktop Gateway.
      - Deployment: Not enabled by default in any deployment.
      - References:
        - Common Vulnerabilities and Exposures: CVE-2020-0609
      - Classification: Vulnerability - Other
      - Protocol: UDP (Generic)
      - Platform: Windows Server Application or Service

    36883: UDP: Microsoft Remote Desktop Gateway Out-of-Bounds Write Vulnerability
      - IPS Version: 3.6.2 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Category: Exploits
      - Severity: Critical
      - Description: This filter detects an attempt to exploit an out-of-bounds write vulnerability in Microsoft Remote Desktop.
      - Deployment: Not enabled by default in any deployment.
      - References:
        - Common Vulnerabilities and Exposures: CVE-2020-0610
      - Classification: Vulnerability - Other
      - Protocol: HTTP
      - Platform: Windows Client Application

    36885: HTTP: Mozilla Firefox getVRDisplays Use-After-Free Vulnerability
      - IPS Version: 3.6.2 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Category: Exploits
      - Severity: Critical
      - Description: This filter detects an attempt to exploit a use-after-free vulnerability in Mozilla Firefox.
      - Deployments:
        - Deployment: Security-Optimized (Block / Notify)
      - References:
        - Common Vulnerabilities and Exposures: CVE-2016-9896
      - Classification: Vulnerability - Other
      - Protocol: HTTP
      - Platform: Multi-Platform Client Application

    36895: HTTP: SolarWinds Serv-U FTP Server USER_FULL_NAME Stored Cross-Site Scripting Vulnerability
      - IPS Version: 3.6.2 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Category: Vulnerabilities
      - Severity: Critical
      - Description: This filter detects an attempt to exploit a cross-site vulnerability in SolarWinds Serv-U FTP Server.
      - Deployments:
        - Deployment: Security-Optimized (Block / Notify)
      - References:
        - Common Vulnerabilities and Exposures: CVE-2019-13182
      - Classification: Vulnerability - Input Validation (Command injection, XSS, SQL injection, etc)
      - Protocol: HTTP
      - Platform: Windows Server Application or Service

    36896: HTTP: Mozilla Firefox libGLES Memory Corruption Vulnerability
      - IPS Version: 3.6.2 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Category: Exploits
      - Severity: Critical
      - Description: This filter detects an attempt to exploit a memory corruption vulnerability in Mozilla Firefox.
      - Deployments:
        - Deployment: Security-Optimized (Block / Notify)
      - References:
        - Common Vulnerabilities and Exposures: CVE-2016-9897
      - Classification: Vulnerability - Other
      - Protocol: HTTP
      - Platform: Multi-Platform Client Application

    36918: HTTP: Microsoft SharePoint Information Disclosure Vulnerability
      - IPS Version: 3.6.2 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Category: Vulnerabilities
      - Severity: Critical
      - Description: This filter detects an attempt to exploit an information disclosure vulnerability in Microsoft SharePoint.
      - Deployments:
        - Deployment: Security-Optimized (Block / Notify)
      - References:
        - Common Vulnerabilities and Exposures: CVE-2019-1443 CVSS 3.5
      - Classification: Vulnerability - Input Validation (Command injection, XSS, SQL injection, etc)
      - Protocol: HTTP
      - Platform: Windows Server Application or Service

    36927: HTTP: Citrix Application Delivery Controller (ADC) Directory Traversal Vulnerability
      - IPS Version: 3.6.2 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Category: Vulnerabilities
      - Severity: Critical
      - Description: This filter detects an attempt to exploit a directory traversal vulnerability in Citrix Application Delivery Controller (ADC).
      - Deployments:
        - Deployment: Default (Block / Notify)
        - Deployment: Performance-Optimized (Disabled)
      - References:
        - Common Vulnerabilities and Exposures: CVE-2019-19781
      - Classification: Vulnerability - Input Validation (Command injection, XSS, SQL injection, etc)
      - Protocol: HTTP
      - Platform: Multi-Platform Server Application or Service

  Modified Filters (logic changes):
    * = Enabled in Default deployments

    31852: TLS: OpenSSL ChangeCipherSpec Security Bypass Vulnerability
      - IPS Version: 3.6.2 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Detection logic updated.

    33692: HTTP: Microsoft SharePoint EntityInstanceIdEncoder Insecure Deserialization Vuln (ZDI-19-181)
      - IPS Version: 3.6.2 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Detection logic updated.

    33976: RPC: Advantech WebAccess Node bwdraw Out-Of-Bounds Write Vulnerability (ZDI-19-584)
      - IPS Version: 3.6.2 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Description updated.
      - Detection logic updated.
      - Vulnerability references updated.

    35026: HTTP: Red Lion Crimson CD31 File Parsing Use-After-Free Vulnerability (ZDI-19-788)
      - IPS Version: 3.6.2 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Name changed from "35026: ZDI-CAN-7645: Zero Day Initiative Vulnerability (Red Lion Crimson)".
      - Description updated.
      - Detection logic updated.
      - Vulnerability references updated.

    35055: RPC: Advantech WebAccess Node BwOpcBs Buffer Overflow Vulnerability (ZDI-19-1010)
      - IPS Version: 3.6.2 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Detection logic updated.
      - Vulnerability references updated.

    36204: SMTP: Server Connection Attempt Response 535
      - IPS Version: 3.6.2 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Detection logic updated.

    36312: HTTP: Advantech WISE-PaaS/RMM AccountMgmt activateAccount XML Information Disclosure (ZDI-19-953)
      - IPS Version: 3.6.2 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Name changed from "36312: ZDI-CAN-9097: Zero Day Initiative Vulnerability (Advantech WISE-PaaS/RMM)".
      - Severity changed from "Critical" to "High".
      - Description updated.
      - Detection logic updated.
      - Vulnerability references updated.

    36497: HTTP: Advantech WISE-PaaS/RMM SQLMgmt insertData SQL Injection Vulnerability (ZDI-19-957)
      - IPS Version: 3.6.2 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Name changed from "36497: ZDI-CAN-9145: Zero Day Initiative Vulnerability (Advantech WISE-PaaS/RMM)".
      - Severity changed from "Critical" to "High".
      - Description updated.
      - Detection logic updated.
      - Vulnerability references updated.

    36531: HTTP: Advantech WISE-PaaS/RMM UpgradeMgmt Directory Traversal Vulnerability (ZDI-19-958)
      - IPS Version: 3.6.2 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Name changed from "36531: ZDI-CAN-9101: Zero Day Initiative Vulnerability (Advantech WISE-PaaS/RMM)".
      - Description updated.
      - Detection logic updated.
      - Vulnerability references updated.

    * 36696: HTTP: Microsoft Office Graph Buffer Overflow Vulnerability
      - IPS Version: 3.6.2 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Name changed from "36696: ZDI-CAN-9427: Zero Day Initiative Vulnerability (Microsoft Office)".
      - Description updated.
      - Detection logic updated.
      - Vulnerability references updated.

    36846: HTTP: WiKID 2FA Enterprise Server InitDevice Cross-Site Scripting Vulnerability
      - IPS Version: 3.6.2 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Description updated.
      - Detection logic updated.
      - Vulnerability references updated.

  Modified Filters (metadata changes only):
    * = Enabled in Default deployments

    * 24745: HTTP: Mozilla Firefox ClearKeyDecryptor Buffer Overflow Vulnerability (ZDI-16-673, ZDI-17-320)
      - IPS Version: 3.1.3 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Name changed from "24745: HTTP: Mozilla Firefox ClearKeyDecryptor Buffer Overflow Vulnerability (ZDI-16-673)".
      - Description updated.
      - Vulnerability references updated.

    36817: HTTP: WordPress CP Contact Form with PayPal Cross-Site Scripting Vulnerability
      - IPS Version: 3.6.2 and after.
      - NGFW Version: 1.0.0 and after.
      - TPS Version: 4.0.0 and after.
      - vTPS Version: 4.0.1 and after.
      - Name changed from "36817: HTTP: WordPress CP Contact Form with Paypal Cross-Site Scripting Vulnerability".
      - Description updated.

  Removed Filters: None
  

Top of the Page
Premium
Internal
Partner
Rating:
Category:
Configure; Troubleshoot; Deploy
Solution Id:
TP000237287
Feedback
Did this article help you?

Thank you for your feedback!

To help us improve the quality of this article, please leave your email here so we can clarify further your feedback, if neccessary:
We will not send you spam or share your email address.

*This form is automated system. General questions, technical, sales, and product-related issues submitted through this form will not be answered.

If you need additional help, you may try to contact the support team. Contact Support

To help us improve the quality of this article, please leave your email here so we can clarify further your feedback, if neccessary:
We will not send you spam or share your email address.

*This form is automated system. General questions, technical, sales, and product-related issues submitted through this form will not be answered.