ビジネスセキュリティ 10.0 SP1 より「セキュリティクライアント」から「セキュリティエージェント」に名称を変更いたしました。
現象
- Microsoft Office とウイルスバスター ビジネスセキュリティ(以下、Biz)クライアントをご利用の一部の環境において、Microsoft Excel (エクセル)でファイルを上書きする時、メッセージが表示されて保存できない場合があります。
- 拡張子”tmp”のファイルが作成され削除できない場合があります。
原因
本現象はBizで使用している検索エンジンの動作の影響により、一部の環境で発生する場合があります。
回避方法
現象が発生しているコンピュータ上で、次の手順を1つずつ実施し、現象が改善するか確認します。改善しなかった場合は次の手順をご実施ください。
以下の案内の中で、レジストリの操作があります。
レジストリは Windows の構成情報が格納されているデータベースです。
レジストリの編集内容に問題があると、システムが正常に動作をしなくなる場合があります。
弊社ではレジストリの編集による、如何なる問題に対しても補償いたしかねます。
レジストリの編集はお客様の責任で行ってください。
なお、レジストリの編集前に、必ずレジストリのバックアップを作成することを推奨いたします。
バックアップ方法の詳細は、ご使用の Windows のヘルプを参照してください。
【1】ファイルマッピング機能の無効化
- Bizサーバの <インストールフォルダ>\PCCSRV にある ofcscan.ini ファイルを開きます。
- [Global Setting] セクションで、「UseMapping」キーを追加して、値を「0」に設定します。
[Global Setting]
UseMapping=0 - Bizサーバの管理コンソールを開き、 [管理] → [グローバル設定] の順に選択します。
- [保存] をクリックして設定をクライアントに配信します。
- Bizクライアントプログラムに次のレジストリキーが自動的にインストールされます。
パス: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VSApiNt\Parameters
キー: UseMapping
値: 0
【2】TmfilterBypassSearchIdx の有効化
- Bizサーバの <インストールフォルダ>\PCCSRV にある ofcscan.ini ファイルを開きます。
- [Global Setting] セクションで、「TmfilterBypassSearchIdx」キーを追加して、値を「1」に設定します。
[Global Setting]
TmfilterBypassSearchIdx=1 - Bizサーバの管理コンソールを開き、 [管理] → [グローバル設定] の順に選択します。
- [保存] をクリックして設定をクライアントに配信します。
- Bizクライアントプログラムに次のレジストリキーが自動的にインストールされます。
パス: HKLM\SYSTEM\CurrentControlSet\Services\tmfilter\Parameters
キー: BypassSearchIdx
値: 1
【3】AvoidExcelSaveIssue の有効化
- Bizサーバの <インストールフォルダ>\PCCSRV にある ofcscan.ini ファイルを開きます。
- [Global Setting] セクションで、「AvoidExcelSaveIssue」キーを追加して、値を「1」に設定します。
[Global Setting]
AvoidExcelSaveIssue=1 - Bizサーバの管理コンソールを開き、 [管理] → [グローバル設定] の順に選択します。
- [保存] をクリックして設定をクライアントに配信します。
- Bizクライアントプログラムに次のレジストリキーが自動的にインストールされます。
パス: HKLM\SYSTEM\CurrentControlSet\Services\tmfilter\Parameters
キー: AvoidExcelSaveIssue
値: 1
【4】Windows Search サービスの無効化
- Bizクライアントがインストールされたコンピュータ上でクイック検索欄に「services.msc」と入力し、実行します。
- 一覧から「Windows Search」を確認し、停止あるいはプロパティから [スタートアップの種類] を無効にします。(※一覧に「Windows Search」が存在しない場合は、本作業は必要ありません)